Call Search
     

New to Ham Radio?
My Profile

Community
Articles
Forums
News
Reviews
Friends Remembered
Strays
Survey Question

Operating
Contesting
DX Cluster Spots
Propagation

Resources
Calendar
Classifieds
Ham Exams
Ham Links
List Archives
News Articles
Product Reviews
QSL Managers

Site Info
eHam Help (FAQ)
Support the site
The eHam Team
Advertising Info
Vision Statement
About eHam.net

donate to eham
   Home   Help Search  
Pages: Prev 1 2 3 4 [5] 6 7 8 9 10 ... 263 Next   Go Down
 
Subject Started by Replies Views Last post
Bad regulator in FT-101E « 1 2 » KD5FPO 19 14409 Last post February 21, 2011, 06:00:30 PM
by KD5FPO
Realistic HTX-100 Microprocessor UC1208 « 1 2 » KI4VHJ 27 14400 Last post November 26, 2010, 10:05:05 AM
by A22EW
Kenwood TS-520 transmitter problems KD4ACG 14 14347 Last post November 25, 2011, 03:43:52 PM
by KD4ACG
IC-740 - No power output VA6KIT 14 14292 Last post November 03, 2013, 08:05:12 PM
by W9GB
IC-756 : Trying to locate q801 & q802 WB4IUY 12 14222 Last post October 08, 2013, 02:43:37 PM
by W9GB
ASTRON SS-25M NS0R 6 14178 Last post August 06, 2014, 12:56:21 PM
by NS0R
Who To Send My Radios For Repairs? IC740AZ 13 14174 Last post October 01, 2013, 07:40:24 AM
by NK7Z
Radio Shack HTX-242 Help « 1 2 3 » YONU 35 14080 Last post January 06, 2013, 07:42:20 AM
by K1CJS
FT-857D S-meter broken - Help! « 1 2 » AE5NE 21 14042 Last post April 02, 2013, 07:53:20 PM
by VE3FAX
Stuck scanner: Radio Shack Pro-2053 N0RWW 7 13980 Last post April 10, 2013, 11:33:44 AM
by K1CJS
Reset FT-897D to Factory Settings? W7RUE 3 13954 Last post March 24, 2013, 05:47:44 PM
by W7RUE
Kenwood Repair.. TM-255A will not Transmit « 1 2 » W6TGE 16 13907 Last post July 01, 2013, 01:03:11 PM
by W6TGE
Rebuilding a 2 meter power module... SAV24??? KC2ILQ 8 13844 Last post March 29, 2005, 09:03:59 AM
by KH6JUKSLANT1
Pop Spilled on Radio « 1 2 » AC9Y 27 13836 Last post March 30, 2014, 05:23:27 PM
by KD8MJR
Scrambler - Icom UT110 02 - Rolling Voice Scrambl 9K2AI 4 13685 Last post June 21, 2008, 12:49:20 PM
by W3LK
Power problem with TS-430S « 1 2 » KD4SBY 25 13648 Last post October 27, 2011, 01:41:29 PM
by KD4SBY
Kenwood TR-7400A Power Cord FLORIDAMARINE 13 13600 Last post November 24, 2013, 05:22:09 AM
by W9GB
Browning golden eagle 3 « 1 2 » KB1GTX 22 13588 Last post November 29, 2012, 05:14:45 PM
by MAGNUM257
FRG-8800 Flasing display ? G0LGJ 11 13584 Last post June 06, 2013, 04:18:56 AM
by RADIOPATEL
Alinco dx-77t finals failure « 1 2 » KF5AIE 27 13578 Last post February 11, 2016, 06:44:05 AM
by KF5AIE
Pages: Prev 1 2 3 4 [5] 6 7 8 9 10 ... 263 Next   Go Up
 
Topic you have posted in
Normal Topic
Hot Topic (More than 15 replies)
Very Hot Topic (More than 25 replies)
Locked Topic
Sticky Topic
:  
Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!