Call Search
     

New to Ham Radio?
My Profile

Community
Articles
Forums
News
Reviews
Friends Remembered
Strays
Survey Question

Operating
Contesting
DX Cluster Spots
Propagation

Resources
Calendar
Classifieds
Ham Exams
Ham Links
List Archives
News Articles
Product Reviews
QSL Managers

Site Info
eHam Help (FAQ)
Support the site
The eHam Team
Advertising Info
Vision Statement
About eHam.net

donate to eham
   Home   Help Search  
Pages: [1]   Go Down
  Print  
Author Topic: Lap top PS RFI  (Read 3114 times)
K7PWE
Member

Posts: 1




Ignore
« on: August 06, 2017, 04:32:07 PM »


I need to have help with a computer power supply that when plugged into my computer causes RFI in my Yeasu FT-991. It is not a lot but one or two S units can sometimes make a big difference.

When I unplug the PS from the laptop, the RFI goes away. Sure, I can leave it unplugged, but sometimes my radio patients outlasts the computer battery.

Where should I place the choke, and is there a particular type of choke that I should use?

Thanks!

Pat - K7PWE
Logged
K0UA
Member

Posts: 1345




Ignore
« Reply #1 on: August 07, 2017, 08:01:39 AM »

All RFI remedy's are mostly trial and error.  I would try and place a snap on choke right up next to the power supply "lump" on the AC power cord as close to the power supply lump as possible, and put as many turns of the power cord in the snap on as possible.  you may not be able to get more than 2 turns in most of the normal snap on's.  Then try the DC cord coming out of the power supply again right up next to the power supply itself.  While keeping all of the previous snap on's still in place try the DC cord right up next to the computer.  Again putting as many turns as you can get in the snap on's wire channel as you can get and still get the snap on choke closed. 

 A big toroidal choke might work better than the little snap on's but the problem becomes getting the ends of the cords thru the toroid.  After that comes surgery.  Opening up the power supply case and using bypass capacitors across the DC line first and then the AC line if there is room inside the power supply case that you cracked/sawed open to put a cap with enough voltage rating 600 volts and a .01uf.  But this is a last resort, and maybe beyond your capabilities.  Next is build your own clean linear supply.

It is all a matter of how bad do you want this noise gone..
Logged
KC1BMD
Member

Posts: 608




Ignore
« Reply #2 on: August 07, 2017, 10:21:33 AM »

If the snap on ferrites don't work, it might be easier to try another brand supply (e.g. HP). You didn't mention what you have but I don't get any RFI from the p/supply that came with my HP laptop.
Logged
KC2MMI
Member

Posts: 812




Ignore
« Reply #3 on: August 08, 2017, 12:54:34 PM »

The RFI could be caused by the charging circuit IN your laptop, in which case nothing on the power brick or cord may help. If the noise is radiating out of the laptop and down the power cord, putting the choke right next to the laptop would work. But many already have that from the factory.

If the power brick is the problem, putting the choke at the power brick will help.

You might ask the laptop maker if they are aware of this issue and if they have any corrections for it. Slim chance but worth pursuing.
Logged
KC1BMD
Member

Posts: 608




Ignore
« Reply #4 on: August 11, 2017, 12:30:20 PM »

The RFI could be caused by the charging circuit IN your laptop,...

That certainly could be the cause. I suggested trying another power supply (brick) if one was available since it might be easier. Alternatively, trying another laptop with the same power supply (if compatible) might yield a clue. Simple swapping might tell if it's one or the other (unless all substitute equipment is noisy too Smiley).
« Last Edit: August 11, 2017, 12:32:27 PM by KC1BMD » Logged
ZENKI
Member

Posts: 1421




Ignore
« Reply #5 on: August 26, 2017, 07:43:25 PM »

The bad lop top power supplies  when they cause RFI nothing you will do  will fix the problem.  Matters are made worst with the after market Chinese power supplies that meet no EMC standards.

The best thing to do is call the manufacturer up and complain or take it back to the store. A properly designed laptop that meets international, FCC and other FCC EMC standards should not cause any interference. You have a legal leg to stand on if you have a name brand laptop and power supply.

Thats what I do  these days because despite having expertise from working in an EMC LAB with access to the best equipment I have  stopped wasting my time  and resources fixing junk that cant be fixed. Simplistic ham fixes like toroids  and clip on beads have very minimal impact on junk poorly design products.

If you a low band dx'er I would suggest getting rid of every switch mode power supply in your house. Thats what I have done!

 
Logged
G4LNA
Member

Posts: 144




Ignore
« Reply #6 on: August 26, 2017, 11:47:46 PM »

I had the same problem with a Toshiba Netbook and it's branded PSU, tried ferrite on the input, on the output, on the input and output and nothing helped, it was definitely coming directly from the PSU because when I put the palm of my hand on the PSU the noise reduced.

I cured it by stuffing it in a tin box, slamming the lid shut and kicking it under the bench, that fixed it  Grin
Logged

VK2LEE
Member

Posts: 36


WWW

Ignore
« Reply #7 on: October 13, 2017, 05:17:29 AM »

My Toshiba  laptop power supply also put out 3-4 S points of noise so I have the AC side of the power supply going thru a clip on ferrite TWICE and the DC power supply cord going thru a Ferrite ring 9 times as that is all I could  fit thru it.  I had both ferrites on hand so I don't know what they are, but they worked...  I also noticed that I have wrapped the Toshiba power supply in foil but maybe a tin box sounds better... Hi Hi..  I did try  a non Toshiba power supply once but it was much worse noise wise..

Lee   VK2LEE
Logged

28 years as VK2LEE - The 1st 3 letter L call ever issued - in 1986 -
Pages: [1]   Go Up
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!