Call Search
     

New to Ham Radio?
My Profile

Community
Articles
Forums
News
Reviews
Friends Remembered
Strays
Survey Question

Operating
Contesting
DX Cluster Spots
Propagation

Resources
Calendar
Classifieds
Ham Exams
Ham Links
List Archives
News Articles
Product Reviews
QSL Managers

Site Info
eHam Help (FAQ)
Support the site
The eHam Team
Advertising Info
Vision Statement
About eHam.net

   Home   Help Search  
Pages: Prev 1 2 3 4 5 [6] 7 8 9 Next   Go Down
  Print  
Author Topic: LIDO MOUNTS  (Read 112796 times)
KE5TVB
Member

Posts: 2




Ignore
« Reply #75 on: March 13, 2011, 09:27:34 PM »

It has been about a week since ordering and still nothing shipped. I am going to try and contact them and hope to hear from them. If not, I will give them another week or so then call my CC company. Wish me luck I guess. . .

Ordered on Feb 24th, received and processed by the post office on March 7th, delivered March 10th. Slower that I think necessary on the shipping, but none the less it shipped and arrived. I like the product, it is pretty stout. If you are looking to buy one, do so from one of the online HAM stores that have it in stock.
Logged
PA0MJM
Member

Posts: 1




Ignore
« Reply #76 on: April 22, 2011, 01:02:10 PM »

I ordered a lidomount (LM300) via HRO on 04-11-2011. It was delivered here at my doorstep in the Netherlands by DHL on 04-19-2011.
So no problems here. Perfect service of HRO.

But I had to tighten the gooseneck itself at the the bottom. I removed the 'lock'screw, then I could tighten the goose neck in the floormount by 1/4 turn. Then I replaced a the 'lock'screw by a new one.

Failing quality check?.


73,
Martin, PA0MJM
« Last Edit: April 22, 2011, 01:14:33 PM by PA0MJM » Logged
WT7I
Member

Posts: 1




Ignore
« Reply #77 on: November 08, 2011, 01:22:44 PM »

I wish I had seen this thread before I ordered.  The product I wanted (seat track mount for FTM-350) could only be found on the Lido site (warning sign?).  My order arrived about three weeks after my card was charged.  Unfortunately, the product was useless as shipped.  The mounting stud listed on the website, threaded specifically for the FTM-350, was missing.  After an attempt at the "chat" feature on their website, three emails, and two phone calls, I'm ready to contest the charges on my credit card and contact the better business bureau.
Logged
WB5YDA
Member

Posts: 1




Ignore
« Reply #78 on: November 14, 2011, 12:56:43 PM »

Here it is 2011 and still the same sad story!!! Lido mounts customer service is the absolute worst! They are SO bad, ARRL quit accepting advertisement from them. Still won't return emails, still can't get a hold of them on the phone. Got a mount ordered and it has been over 2 weeks and, Guess What, no mount yet. Stay away from this company!!!!!!!!!!!! BTW, has anyone seen any more replies from this idiot for a couple of years?
« Last Edit: November 14, 2011, 01:08:36 PM by WB5YDA » Logged
N6JRC
Member

Posts: 1




Ignore
« Reply #79 on: December 08, 2011, 09:05:41 AM »

Still a horrible company - very hit and miss, and more miss than hits.  A friend ordered a couple of items and they were received no problem.  My order was placed on October 18 and aside from having the credit card charged, nothing has happened.  3 e-mails, multiple phone calls that all ended up on an answering machine and nothing.  Finally got a notice from Lass Inc. that the order has been shipped.  The notification came from Stamps.com which has nothing to do with the post office.  It's been almost 2 solid months with no response from the company.  Now working with the credit card company to get a refund.  Definitely stay far, far away.  HRO and other large resellers carry their products so shop there - just don't go direct otherwise you're throwing your money away.  Better yet, find another company that makes suitable mounts and give them your business instead.
Logged
LIDOMOUNTS
Member

Posts: 16




Ignore
« Reply #80 on: December 13, 2011, 04:20:18 PM »

Well, it looks like we have a few customer service Issues. LB (WB5YDA)..it looks like your item was delivered. Not true in regards to QST. We are waiting to see if you are keeping the mount or want a refund per our e-mail to you, N6JRC I believe we have spoken on the phone about your refund and I apologize for the bad service.

73's
Jim Newcomb
Lido Mounts
Logged
KE4DRN
Member

Posts: 3714




Ignore
« Reply #81 on: December 13, 2011, 07:34:08 PM »

Mr. Newcomb,

QST will not run your ads because of poor customer service,
Lido will not appear on the QST advertisers listing

http://www.arrl.org/meet-our-business-partners

similar service issues are also posted on the harley davidson forum.

http://www.hdforums.com/forum/touring-models/350415-gps-mount-dealer-problem.html

Lido also has a F rating in the BBB site.

Interesting the business address for Lido is inside
a nice gated community in Irvine, CA.

30 Shade Tree, Irvine, CA 92603

Here is direct response from QST Sales Manager Ms. Jahnke,

I am so sorry that you are experiencing difficulties. We too have repeatedly attempted to contact this company. You will not find an ad in QST for them but that is little consolation. I hope whatever action you choose to take produces results.

73,

Debbie Jahnke, K1DAJ
Sales Manager, Advertising and Business Services
ARRL: the national association for Amateur Radio
Phone: 860-594-0329
Email: djahnke@arrl.org

http://www.eham.net/forums/CompanyReviews/2450


Regards
« Last Edit: December 13, 2011, 07:36:09 PM by KE4DRN » Logged
LIDOMOUNTS
Member

Posts: 16




Ignore
« Reply #82 on: December 14, 2011, 11:26:41 AM »

KE4DRN,

We have had issues in the past. We have moved on and are trying to fix what has happened in the past by offering great service.

I was not aware of the letter from Ms. Jahnke. She has never made contact with us. I am sure you would not fabricate this. But my goal is not to defend our poor service in the past.
We are creating new and innovative mounting solutions for the new radios that are coming out. Since we concentrate on the Ham Radio Market, we know the proper attachments for the radios that are on the market today. Not to say we are the only ones.
I do live in a gated community, our address is on our site and we do not try to hide where we are at. I attend many hamfests. I am not sure what your purpose of noting that we live in a gated community.

With all of that said, if we have wronged you in the past I am sorry.

Take care,

Jim Newcomb
Lido Mounts
Logged
KD0JPE
Member

Posts: 1




Ignore
« Reply #83 on: January 07, 2012, 04:47:57 PM »

I ordered a Yaesu Cup Holder mount on 01/02/2012, with standard shipping, and received it on 01/07/2012. I promptly received an email confirmation of the order and an additional e-mail, with a tracking number, when it was sent. The mount works very well for my FTM-350 and I am pleased with it.

I have three other LIDO mounts and this is the second time that I've ordered directly. The other two were purchased from HRO. If you are concerned about ordering from LIDO, you might want to purchase from one of the online amateur radio retailers instead.

I should add that I had a problem with my first direct order, a year-and-a-half ago, and Jim solved it quickly and to my satisfaction.

Just my experience,

John, KD0JPE
Logged
N6GYY
Member

Posts: 4




Ignore
« Reply #84 on: March 03, 2012, 09:57:30 PM »

I wish I had run across this thread before ordering from Lido Mounts. It seems that I am experiencing a repeat of what so many others have complained about with this company in the past. It does not appear as if much has changed, despite Jim saying he was turning over a new leaf.
I ordered a mount for my FTM-350 on 2/13/12. After hearing nothing for a week, and living just 30 miles from Irvine, I placed a call and got a reply that it was back ordered and would be going out on the following Friday. (24th).
I got an email from Stamps.com on Saturday, the 25th, and since then nothing. No updates from the tracking number, the post office has no record of receiving the package, and now I cannot get in touch with anyone at the company.
All phone numbers, including the one "Jim" gave me, which he said was his cell number, go directly to voicemail and no calls have been returned.  Angry
Monday I am going to cancel my order and get the parts elsewhere. I have located what I need at http://www.pro-fit-intl.com/.
I would suggest to all to think twice before placing an order with Lido Mounts.
Just my experience, but not a very pleasant experience,

Chuck, N6GYY
« Last Edit: March 04, 2012, 07:52:28 PM by N6GYY » Logged
KRAKEN
Member

Posts: 1




Ignore
« Reply #85 on: June 14, 2012, 05:28:01 PM »

Another complaint here.  They took my money but delivered no product.  No response to emails or voice mails.  I just got off the phone with my bank filing a fraud claim against Lido.  I'm headed to HRO tomorrow to ask why they carry products from such a company.
Logged
N3SCS
Member

Posts: 1




Ignore
« Reply #86 on: June 21, 2012, 10:38:42 AM »

I'm another sucker for Lido mounts. They are a two bit reseller with terrible customer service record. I too ordered a 300 mount for the Kenwood. Imagine it arriving with a universal mount (nothing that would fit the Kenwood). When i called, no answer. Then the email trick and still no answer.  Finally sent it back due to poor customer service and unusable mount.  Now fighting to get a credit on my CC. 

Can't believe HRO uses the guy as well (my guess is they get a call back).  HRO also didn't have the Kenwood adapter. I did source the right stuff from Arkon (my guess is they use the same manufacturer) and they had the right mounts I needed and customer service (yes they can answer a phone). 

Lido is a poor excuse for a company. Of course saying this is a real company is a stretch.

Steve
N3SCS
Logged
N2AYM
Member

Posts: 3




Ignore
« Reply #87 on: August 15, 2012, 03:31:41 PM »

Yes they do have a range of unique products like that adhesive pad
which is what i have been having the problem with and of course i
can not get a hold of these people either via email or phone so i may
have to make a hambo repair in order to get my control head re-mounted.
It seems like they have a reliability problem with the adhesive on those
round pads.
Logged
KE4DRN
Member

Posts: 3714




Ignore
« Reply #88 on: August 15, 2012, 05:28:40 PM »

Hi,

I agree, no way to run any business, looks like we should be
getting another post from Jim at Lido about how they want to
move on and give great customer service.

73 james
Logged
KB4OIF
Member

Posts: 67




Ignore
« Reply #89 on: August 22, 2012, 10:26:14 AM »

Placed my order the other day. They have cashed my check.  No shipping info.  No one answers the phone number on the web site. No one answers the email that was sent.  Believe me, when I get the mount, I will not order from these guys anymore.     I worked in the customer service area for over 20 years and this is a hell of a way to run a company.   On a scale of 0-10 ten being high.  They get a ZERO. 
Logged
Pages: Prev 1 2 3 4 5 [6] 7 8 9 Next   Go Up
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!