Call Search
     

New to Ham Radio?
My Profile

Community
Articles
Forums
News
Reviews
Friends Remembered
Strays
Survey Question

Operating
Contesting
DX Cluster Spots
Propagation

Resources
Calendar
Classifieds
Ham Exams
Ham Links
List Archives
News Articles
Product Reviews
QSL Managers

Site Info
eHam Help (FAQ)
Support the site
The eHam Team
Advertising Info
Vision Statement
About eHam.net

   Home   Help Search  
Pages: Prev 1 [2]   Go Down
  Print  
Author Topic: 3-500Z Tubes for Drake L-4B  (Read 4793 times)
WB2WIK
Member

Posts: 20630




Ignore
« Reply #15 on: March 23, 2011, 11:08:43 AM »

To everyone that sent a reply on something to check, Thanks!!

It took me a week to get through all the suggestions. Still not operating.

I was able to get a Drake repair person to come here and take a look at it and he said there was definately something wrong and he needed to take it to his shop and check it out more thoughouly. So that is where this issue is at right now. Waiting to hear back from him.

Was it Jeff, WA8SAJ?  If so, you're in good hands.

Quote
But, one of my original questions did not get answered.
Is there a way to check the 3-500Z tubes to see if one or both is bad??

Best test is in the amplifier.  You can operate one tube at a time for testing purposes.  But of course the amplifier has to actually "work" to be an effective test bed.

Logged
W8RID
Member

Posts: 45




Ignore
« Reply #16 on: March 23, 2011, 12:39:27 PM »

Steve:

No it was not WA8SAJ. I contacted Jeff about a year ago when I started trying to trouble shoot this Amp. He does not work on them any more. He has scaled back what he works on. But I always call him when I have to find out if he can fix it or where I should take it.

The person I'm using is W8CQ, Jeff Weinberg. He is a little farther away but he also came highly recommended. (Harbach Electronics, Polk, OH)

Bob
W8RID
Logged
Pages: Prev 1 [2]   Go Up
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!