Call Search
     

New to Ham Radio?
My Profile

Community
Articles
Forums
News
Reviews
Friends Remembered
Strays
Survey Question

Operating
Contesting
DX Cluster Spots
Propagation

Resources
Calendar
Classifieds
Ham Exams
Ham Links
List Archives
News Articles
Product Reviews
QSL Managers

Site Info
eHam Help (FAQ)
Support the site
The eHam Team
Advertising Info
Vision Statement
About eHam.net

   Home   Help Search  
Pages: [1]   Go Down
  Print  
Author Topic: Kenwood TS-940S RIT/XIT Problem  (Read 1035 times)
W1EY
Member

Posts: 6




Ignore
« on: June 09, 2012, 11:11:57 AM »

I have a recently purchased and pristine (serial #70900XX) with only one problem (so far).  The RIT/XIT control knob turns, but is non-functional.  The kHz indicator flashes, but does not change frequency.  Has anyone else had this problem, or is there a Kenwood help group to assist?  Thanks for your thoughts.
Logged
KA4POL
Member

Posts: 2028




Ignore
« Reply #1 on: June 09, 2012, 11:45:05 AM »

Check out http://groups.yahoo.com/group/ts-940/
Logged
W5DQ
Member

Posts: 1209


WWW

Ignore
« Reply #2 on: June 13, 2012, 02:04:20 PM »

I have a recently purchased and pristine (serial #70900XX) with only one problem (so far).  The RIT/XIT control knob turns, but is non-functional.  The kHz indicator flashes, but does not change frequency.  Has anyone else had this problem, or is there a Kenwood help group to assist?  Thanks for your thoughts.

Sorry to ask the obvious (I know it is a stupid question and not meant to insult anyone) but you have turned on the RIT/XIT functions, correct? They are the 2 buttons just under the secondary LCD display and when cycled ON, the display indicates "RIT" and "XIT" labels.

I mention the because I have a TS-940S and occasionally I forget to turn them on and have to stop and look again when I turn the RIT knob and nothing happens.

Gene W5DQ
Logged

Gene W5DQ
Ridgecrest, CA - DM15dp
www.radioroom.org
Pages: [1]   Go Up
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!