eHam

eHam Forums => Elmers => Topic started by: W8JJI on July 17, 2004, 12:31:15 PM



Title: FT 897 high SWR problem
Post by: W8JJI on July 17, 2004, 12:31:15 PM
No matter what antenna or dummy load is connected to the HF antenna jack the radio's high swr indicator is flashing resulting in almost no RF output on HF.

VHF and UHF TX work fine.

It seems like it "just happened", the radio has been sitting unused for about 2 months, I hooked it up the other day and discovered this problem .

Is there anything I can do to fix this problem on my own ?

Thanks!


Title: FT 897 high SWR problem
Post by: K1CJS on July 17, 2004, 01:20:58 PM
Did you just reconnect the antenna cable to the rig?  If so, did the antenna connector move at all (was it loose) when the cable ws reconnected?  I suspect a broken connection to the HF connector or at the board.

Just taking the cover off and tightening the connector may solve your problem--or reveal the problem to you.  At the same time make sure the other connectors are also tight--and corrosion free.  Even a little oxidation could affect the SWR readings.

Good luck and 73!


Title: FT 897 high SWR problem
Post by: W8JJI on July 17, 2004, 01:45:56 PM
I checked the connector and it is solid and clean.

Any other suggestions ?

(I wish I could bypass the high SWR protection circuit in the radio alltogether)


Title: FT 897 high SWR problem
Post by: K0RFD on July 17, 2004, 02:07:49 PM
W8JJI wrote:
(I wish I could bypass the high SWR protection circuit in the radio alltogether)


That would be kind of like putting a penny in the fuse box, wouldn't it?


Title: FT 897 high SWR problem
Post by: WIRELESS on July 17, 2004, 03:20:33 PM
At this point you need to test it into a dummy load.  If the swr stays high your radio has a problem, if the swr goes down you have a bad antenna/feedline.


Title: FT 897 high SWR problem
Post by: WIRELESS on July 17, 2004, 03:25:10 PM
Your radio probably needs service but check the coax again if it is different than what you use on vhf.  You can't assume a high swr is really high, like 10:1.  The radio maybe seeing an swr of 2 or 3:1 and indicating high swr.  I have seen some cheap dummy loads become intermittent because of overheating.  If the loads are good and coax is good, you have a defective radio.


Title: FT 897 high SWR problem
Post by: K1CJS on July 17, 2004, 08:06:41 PM
Did you make sure the interior connector of the SO-239 is tight against the PL-259 pin?  It sounds like a stupid question, but if that inner connector isn't friction fit against the plug pin that would cause high SWR too.  However, that is a long shot.  The circuit board could have been cracked by a drop or a bang (it doesn't happen too often, but it can happen)
causing an open in the antenna circuit.  Having the rig looked at is probably a good idea now.