Call Search
     

New to Ham Radio?
My Profile

Community
Articles
Forums
News
Reviews
Friends Remembered
Strays
Survey Question

Operating
Contesting
DX Cluster Spots
Propagation

Resources
Calendar
Classifieds
Ham Exams
Ham Links
List Archives
News Articles
Product Reviews
QSL Managers

Site Info
eHam Help (FAQ)
Support the site
The eHam Team
Advertising Info
Vision Statement
About eHam.net

donate to eham
   Home   Help Search  
Pages: [1]   Go Down
  Print  
Author Topic: IC-910H TX power fail on 2m & 70cm  (Read 467 times)
VK4KX
Member

Posts: 14




Ignore
« on: August 28, 2017, 06:57:02 PM »

I have an IC-910 with a couple if issues if anyone has come across this before.
The first one which kis minor in comparison is that when I have the UHF band in the second band below the main it will start scrolling or scanning in frequency, even if it's a memory channel and yes I have checked that it's not in scan mode.

Now here is the second issue!
It has just dropped in output power on both 2m & 70cm to an unreadable amount on an external meter and micro deflection on the screen power reading.
23 CM is ok as it's the add on module but I don't know what caused 2m & 70cm TX Power to fail as the SWR is good on both those bands antennas, perhaps I was rag chewing too long at high power.
Here in VK the cost of both sets of finals is quite high but they are available and for me this is a last option, so I'm thinking something prior to the output finals has failed.

Any help would be appreciated.

Regards
VK4KX, Bernie
Logged
Pages: [1]   Go Up
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!