Call Search
     

New to Ham Radio?
My Profile

Community
Articles
Forums
News
Reviews
Friends Remembered
Strays
Survey Question

Operating
Contesting
DX Cluster Spots
Propagation

Resources
Calendar
Classifieds
Ham Exams
Ham Links
List Archives
News Articles
Product Reviews
QSL Managers

Site Info
eHam Help (FAQ)
Support the site
The eHam Team
Advertising Info
Vision Statement
About eHam.net

donate to eham
   Home   Help Search  
Pages: [1]   Go Down
  Print  
Author Topic: Icom 7300 hijacking my PC's sound  (Read 2405 times)
KC1GCG
Member

Posts: 139




Ignore
« on: December 31, 2017, 11:11:57 AM »

Well I was debating on whether here or a PC user forum would be the place to start but since its all related to Ham software and Hardware I figured someone to post here first as someone might have been thru the same issues or have some thoughts.
My problem, while not show stopping, just annoying, is related to my  Icom 7300 and I also use HRD software. Seems like both of them are co conspirators in my problem:)
It started when I recently got rehooked on playing some computer games and the sound in the games would not work unless I shut off the Icom 7300, closed HRD and rebooted the PC and then leave the 7300 of and not load HRD. . Thinking its some kind of com port or USB conflict?
Just a bit of a pain as I have recently been in the mood to use my Ham stuff for a while and theN game for a while then back to ham etc etc but each time I have to go thru closing things down and rebooting.
Ideally it would be nice to leave the game running in the back ground as well as HRD and the rig on and be able to easily switch between the two addictions! hihi
So as I said not a show stopper but if anyone has some ideas or fixes it would start my New Year out as a happy one!
Happy New Year to all.
John K1JRF
Logged
KS2G
Member

Posts: 767




Ignore
« Reply #1 on: December 31, 2017, 12:04:42 PM »

Check in Control Panel to see which sound cards are listed and which is set as default.

My guess is that when you boot the computer with the 7300 on, it sees the rig's sound card as default, so it's trying to send the sounds from your games to the 7300.

Re-set the computer's sound card as default in Control Panel.
Logged
VA3VF
Member

Posts: 1105




Ignore
« Reply #2 on: December 31, 2017, 03:41:30 PM »

Well I was debating on whether here or a PC user forum would be the place to start but since its all related to Ham software and Hardware I figured someone to post here first as someone might have been thru the same issues or have some thoughts.
My problem, while not show stopping, just annoying, is related to my  Icom 7300 and I also use HRD software. Seems like both of them are co conspirators in my problem:)
It started when I recently got rehooked on playing some computer games and the sound in the games would not work unless I shut off the Icom 7300, closed HRD and rebooted the PC and then leave the 7300 of and not load HRD. . Thinking its some kind of com port or USB conflict?
Just a bit of a pain as I have recently been in the mood to use my Ham stuff for a while and theN game for a while then back to ham etc etc but each time I have to go thru closing things down and rebooting.
Ideally it would be nice to leave the game running in the back ground as well as HRD and the rig on and be able to easily switch between the two addictions! hihi
So as I said not a show stopper but if anyone has some ideas or fixes it would start my New Year out as a happy one!
Happy New Year to all.
John K1JRF

I'm not familiar with HRD, but properly written software will only use the card that is selected in the settings of said software. Ex: In WSJT-X, you select the card to use, and that's it, PC default or not. It's not the default card in my case, and it never causes problems.
Logged
VE3YF
Member

Posts: 579




Ignore
« Reply #3 on: December 31, 2017, 03:59:57 PM »

Well I was debating on whether here or a PC user forum would be the place to start but since its all related to Ham software and Hardware I figured someone to post here first as someone might have been thru the same issues or have some thoughts.
My problem, while not show stopping, just annoying, is related to my  Icom 7300 and I also use HRD software. Seems like both of them are co conspirators in my problem:)
It started when I recently got rehooked on playing some computer games and the sound in the games would not work unless I shut off the Icom 7300, closed HRD and rebooted the PC and then leave the 7300 of and not load HRD. . Thinking its some kind of com port or USB conflict?
Just a bit of a pain as I have recently been in the mood to use my Ham stuff for a while and theN game for a while then back to ham etc etc but each time I have to go thru closing things down and rebooting.
Ideally it would be nice to leave the game running in the back ground as well as HRD and the rig on and be able to easily switch between the two addictions! hihi
So as I said not a show stopper but if anyone has some ideas or fixes it would start my New Year out as a happy one!
Happy New Year to all.
John K1JRF

John

This might be the problem, did your computer get some updates recently. I am presuming you are using Windows. I have problems from time to time where Windows 10 updates will play with my comport settings as well as device settings and change things around. Every time a big update comes by I have to go in and change things back, and I do this all thru the control panel etc before opening any of my Amateur Radio programs, thus when I open the Amateur Radio programs all is ok.
Logged

73 De Mike
VE3YF

http://www.ve3yf.com
AE5GT
Member

Posts: 108




Ignore
« Reply #4 on: January 02, 2018, 11:20:44 AM »

It sounds to me as if HRD is grabbing either the soundstream or the soundcard for its exclusive use and then not releasing it before it closes . Or possibly the soundcards are being re-indexed.
Logged
N8WCR
Member

Posts: 2




Ignore
« Reply #5 on: January 02, 2018, 12:36:48 PM »

This is because the 7300 has a USB soundcard builtin for doing digital communications and such, so when you turn on the 7300, the computer automagically senses theUSB soundcard and installs it, then it thinks since its a new device you must want it to be the default sound device, so it sets it so.  I have the same issue sometimes when I connect my guitar processor to the computer via USB, it has a sound card device so you can record from it using a DAW program.  It will then use it for the default sound device and surprises the hell out of my when the computer beeps or I play a game it comes through my guitar amp, at a loud volume of course!  When you shut the 7300 off, it will no longer see the device and returns the normal default sound card.

You do not need to reboot the computer, just go into the Control Panel and Sounds, and then select the regular sound card as default.
Logged
K0BT
Member

Posts: 366




Ignore
« Reply #6 on: January 09, 2018, 12:12:16 PM »

Windows 10 has the nasty habit of changing the default sound device to the latest one it sees. This is great if you want to use headphones, but not for this purpose.  

I don't know if it will work, but you might try this...
In Control Panel/Device Manager, under System Devices, disable the High Definition Audio Controller.
« Last Edit: January 09, 2018, 12:16:37 PM by K0BT » Logged
K0BT
Member

Posts: 366




Ignore
« Reply #7 on: January 09, 2018, 07:48:50 PM »

Never mind. Bad idea.  Some forums suggest the Realtek software as  the culprit, so I'll try removing that once I get home.
Logged
Pages: [1]   Go Up
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!