Call Search
     

New to Ham Radio?
My Profile

Community
Articles
Forums
News
Reviews
Friends Remembered
Strays
Survey Question

Operating
Contesting
DX Cluster Spots
Propagation

Resources
Calendar
Classifieds
Ham Exams
Ham Links
List Archives
News Articles
Product Reviews
QSL Managers

Site Info
eHam Help (FAQ)
Support the site
The eHam Team
Advertising Info
Vision Statement
About eHam.net

   Home   Help Search  
Pages: [1]   Go Down
  Print  
Author Topic: My experience with Icom service  (Read 526 times)
WB3DYE
Member

Posts: 20




Ignore
« on: May 02, 2007, 06:43:28 PM »

I have an Icom 706 mk2g. It developed an intermittent. The power would fold back for no reason--even running it into a dummy load.
Sent it to the Icom service center in Washington state. They couldn't duplicate the problem, touched up some solder points and sent it back to me. Worked for a few weeks and the old problem returned.

This time I video taped the problem as it was happening and sent the DVD and the radio back again.  Once again they couldn't duplicate the problem....BUT, seeing was believing when looking at the DVD. They replaced the power amplifer and sent it back. So far, after giving it a good run for it's money--I'm at full power with no fold backs.

The best part of my experience is this: although the radio was many years out of warrenty--they replaced the PA for FREE!!!!!!!!!!!!!

I am sold on Icom and their service!
Logged
KE4SKY
Member

Posts: 1045


WWW

Ignore
« Reply #1 on: May 04, 2007, 06:29:27 AM »

FB!  Thanks for sharing this.
Logged
HA6SST
Member

Posts: 110




Ignore
« Reply #2 on: May 04, 2007, 02:13:08 PM »

Please could you re-post this in the company reviews section? Good news around there is always welcome.

HA6SST
Logged
Pages: [1]   Go Up
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!