Call Search
     

New to Ham Radio?
My Profile

Community
Articles
Forums
News
Reviews
Friends Remembered
Strays
Survey Question

Operating
Contesting
DX Cluster Spots
Propagation

Resources
Calendar
Classifieds
Ham Exams
Ham Links
List Archives
News Articles
Product Reviews
QSL Managers

Site Info
eHam Help (FAQ)
Support the site
The eHam Team
Advertising Info
Vision Statement
About eHam.net

   Home   Help Search  
Pages: [1]   Go Down
  Print  
Author Topic: Modeling a bi-square and getting unexpected answer  (Read 389 times)
KC2ELS
Member

Posts: 60


WWW

Ignore
« on: July 31, 2007, 05:12:51 PM »

First, I'll warn you, I'm an amateur (hee!) when it comes to modeling antennas.  All I know is what I've read in the EZNEC test drive and some online reading, and whatever I screwed up is probably something really simple.

Here's the NEC file:

--start bisquare.nec--
CM This antenna is designed based on the description in the
CM ARRL Antenna Book (20th Edition).
CM The additional quarter-wavelength stub is designed to allow
CM the use of the antenna as a loop at 14.150MHz and
CM as a bi-square at 28.300MHz.
CE
SY haat=10.5   'height above available terrain (10.5 recommended, 5 realistic)
SY side=17.375   '17 feet as per text, 17.375 computed
SY gap=0.041667   'edge-to-center, actual gap is twice this value (0.5in = 0.041667ft)
SY stublen=17.375   'side is quarter wavelength, so is stub
SY sqrside=sqr(side*side/2)   'helps with math
GW   1   23   0   gap   haat   0   gap+sqrside   haat+sqrside   #12
GW   2   23   0   gap+sqrside   haat+sqrside   0   gap   haat+2*sqrside   #12
GW   3   23   0   -1*gap   haat   0   -1*(gap+sqrside)   haat+sqrside   #12
GW   4   23   0   -1*(gap+sqrside)   haat+sqrside   0   -1*gap   haat+2*sqrside   #12
GW   5   19   0   gap   haat+2*sqrside   0   gap   haat+2*sqrside-stublen   #12
GW   6   19   0   -1*gap   haat+2*sqrside   0   -1*gap   haat+2*sqrside-stublen   #12
GS   0   0   0.3048
GE   -1
GN   3   0   0   0   13   0.005
EK
EX   6   1   1   00   1   0      
EX   6   3   1   00   -1   1e-16      
FR   0   0   0   0   28.3   0
EN

--end bisquare.nec--

As described in the book, this antenna should act as a loop at 14MHz and a bi-square at 28MHz.  After last June's post about switches, I learned from WB6BYU that a stub could make the top of the antenna look like a short circuit at 14MHz and an open circuit at 28MHz.  I don't really know how to model a stub, so I guessed that two parallel wires an inch apart would work.  I wasn't sure how to set up a 300 ohm feedline, but I set up two sources 180 degrees out of phase fed to each side.  Those are two big guesses, by the way, and I'm hoping someone can help tell me the right way to do it.

I ran this through 4NEC2 and got some interesting results.  At 28MHz, I get a bowler-hat-shaped gain pattern maxing out at 10.5 dbi at 20 degrees above the horizon, but the SWR is 37.2 at 300 ohms.  At 14MHz, I get a jelly-bean-shaped gain pattern maxing out at 5.67 dbi at 35 degrees above the horizon, but the SWR is a whopping 1424 at 300 ohms!  Why is it so high?  What am I doing wrong?

Thanks in advance for all your help!
Logged
K8GU
Member

Posts: 716


WWW

Ignore
« Reply #1 on: August 01, 2007, 01:18:41 PM »

First of all, I haven't pulled your NEC file into a viewer or run the model because I don't have anything handy at work right now.   I'm not surprised that you're getting unexpected results, though.  Here are some comments:

Use the TL (transmission line) card to specify your transmission lines.  Don't use the wires.

You should only need one source.  This will give you a more accurate interpretation of what the input impedance is.  (And maybe the pattern, too.)

Loops and other antennas with bends in them like this one are sometimes tricky to model.  You have to get the segmentation right.  You might want to increase the number of segments to see how much the input impedance and pattern change.  This is discussed in several ARRL books; although, the one I remember most vividly is the ON4UN book.

The VSWR referenced to 300 ohms, while meaningful, is not the most meaningful way to interpret your input impedance.  Just read the impedance.

Look at the NEC2 manual if you need help with the TL card.  
Logged
KC2ELS
Member

Posts: 60


WWW

Ignore
« Reply #2 on: August 02, 2007, 12:10:54 PM »

I have downloaded the NEC2 manual in PDF and am reading the TL section.

The TL card requires endpoints for both ends of the transmission line.  I've made very short (one-segment) lines as to act as the other end of the stub (and of the 'real' transmission line) but the results that arise from these examples is woefully wrong.

http://wireless.ictp.it/school_2005/download/nec2/nec_part4.pdf is a reprint of an article by Cebik where he explains how to use transmission lines.  Actually, he doesn't really explain how to use transmission lines, but he describes some of how to use them with EZNEC and NEC-Win.  Unfortunately, the figures in the reprint are so fuzzy that I can't read them to get the ideas, and the only example models I have found online for transmission lines are for things like log-periodic arrays which while interesting don't really apply to my situation.

Thanks for the help!  Anyone else, please feel free to comment.  Thanks again!
Logged
K4SAV
Member

Posts: 1786




Ignore
« Reply #3 on: August 03, 2007, 07:39:52 AM »

Your loop is disconnected at the bottom (between the sources).

Also putting current sources in series is dangerous.  Every program handles this differently.  I'm not sure what NEC4 does.  With EZNEC the program has a split source that is handled automatically.  Even with EZNEC you usually can't calculate SWR with multiple sources.  If you are going to use multiple sources, make sure what the program does with it.  Try it both ways.

Jerry, K4SAV
Logged
Pages: [1]   Go Up
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!