Call Search

New to Ham Radio?
My Profile

Friends Remembered
Survey Question

DX Cluster Spots

Ham Exams
Ham Links
List Archives
News Articles
Product Reviews
QSL Managers

Site Info
eHam Help (FAQ)
Support the site
The eHam Team
Advertising Info
Vision Statement

donate to eham
   Home   Help Search  
Pages: Prev 1 [2]   Go Down
Author Topic: Why I sold my FT-2000D  (Read 17147 times)

Posts: 1

« Reply #15 on: November 02, 2008, 03:43:51 AM »

This past week my FT-2000 failed again. It was bought new in Sept. of '07...

It usually "craps out" the same way.....First the sub receiver dies....then the main....

It was the SS weekend and the strongest amateur signal I heard was S6...My local AM station is S8....

Sadly my 1 year extended warranty has run out...

I had Kenwood gear for all of my hamming years (34) but felt as others had that Kenwood is not as much of a big player as in the past.

I really should have bought a "late" FT-1000...oh and learn....


Posts: 14

« Reply #16 on: February 12, 2009, 09:18:39 AM »

I'd be absolutely TICKLED to score a Yaesu FT-2000!  In fact, if I came into a windfall of cash, that's the radio I would run right out and buy.  A friend has one and its a beautiful radio, and works very well.  I don't do all the whizbang measurements of noise floor, IMD, and mess around trying to comprehend what a Roofing filter is.  If I can hear the DX coming in that I can hear on my Heathkit HW-101, then the radio works great.
I sure wish I would come across one of these Outraged FT-2000 owners who was so angry he would sell it to me for a SONG!  THEN I would have a nice radio to replace my HW-101!

Posts: 11

« Reply #17 on: October 14, 2009, 04:49:18 AM »

Greetings. I understand this is an older Thread but I am having serious issues with an FT-2000 that is <3 months old. I apologize if this is not the correct part of the forum to post this but I did not see any other area(s) in the Forum that would be appropriate and specific to the FT-2000. ANY assistance would be greatly appreciated.

As of this writing I do not have my license yet but am working towards same.

Yesterday while sitting in front of the FT-2000 and listening to some broadcasts I simply went to change bands and the front panel display blinked five times and then returned to it's previous state. Now, various functions such as the VFR will only work after a reset and then will cease to function after a few minutes, at which point it will work again once the unit is reset.

The Shift and Width filters works sporadically.

Anyone have any idea as to what the heck is going on here? The firmware is a hair below the latest revision. Indeed, in speaking with Yaesu last month they said it was such a minor revision that it was not worth the trouble to upgrade.

I absolutely refuse to go a month or better without this unit given the short duration with which I have had it. It'll take a week to get to California, most likely be in-house for a month, and then a week back.

Again, any assistance is greatly appreciated.

Thank you!
Pages: Prev 1 [2]   Go Up
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!