Call Search
     

New to Ham Radio?
My Profile

Community
Articles
Forums
News
Reviews
Friends Remembered
Strays
Survey Question

Operating
Contesting
DX Cluster Spots
Propagation

Resources
Calendar
Classifieds
Ham Exams
Ham Links
List Archives
News Articles
Product Reviews
QSL Managers

Site Info
eHam Help (FAQ)
Support the site
The eHam Team
Advertising Info
Vision Statement
About eHam.net

   Home   Help Search  
Pages: Prev 1 2 [3]   Go Down
  Print  
Author Topic: COM Port Mystery  (Read 2617 times)
K5MBV
Member

Posts: 265




Ignore
« Reply #30 on: September 25, 2008, 05:53:10 AM »

Thanks for the reply Frank. There isn't enough similarity to my problem to apply the solution directly, but I tried to duplicate your method as
closely as possible. The problem persists.

At this point I have decided to AVOID ALL TRANSCEIVER
CONTROL SOFTWARE THAT REQUIRES THE USE OF A SERIAL OR
PARALLEL PORT. Our new laptop PCs don't have these ports. I don't know what the problem is and I don't care anymore.

I can wait until the programers CATCH UP to the PC manufacturers even if writing the software is more difficult for them now in the 21st century.

I'm using a rotor control system that connects directly
to a USB port and it works with SATpc32 and other satellite software. It's called the LVB Tracker.
It is a small box with software and can be bought from AMSAT.

Logged
AA6YQ
Member

Posts: 1648


WWW

Ignore
« Reply #31 on: September 25, 2008, 09:48:44 AM »

I have been developing rig control software (Commander) for the past ~15 years. I make it available for free, and I support it across a broad range of transceivers. Given the large number of variables involved -- serial port hardware, usb port hardware, Windows and its drivers, connectors, cables, transceivers -- I included diagnostic capabilities that reveal exactly what's being sent from PC to transceiver and vice versa. Over the years, I've worked directly with hundreds of users to overcome connectivity problems, including several of the "Can Not Open COM Port x" variety.

Every PC-controllable Icom, Kenwood, Yaesu, Alinco, and Elecraft HF transceiver uses a serial asynchronous protocol at either TTL or RS-232 levels. The *only* way to control these transceivers is via a serial port interface -- either directly or via a USB adaptor that presents itself through Windows as one or more serial ports.

Without knowing what application you are running that is producing the "Can Not Open COM Port x" message, there is no way to know what that message means. It could be anything from a defect in that application to some other application on your PC already having that serial port open to a defect in Windows. Back on September 7th, I posted a message here asking you what application you were using, but you never responded. Unless you were already running Commander, I'd have suggested that you temporarily install it so we could methodically get to the bottom of your problem -- but you never responded to my post.

At this point, I suggest that you write your own USB device driver and transceiver control application. Then you'll have dominion over all of the variables, and can solve whatever problems arise entirely on your own.

    73,

        Dave, AA6YQ


Logged
K5MBV
Member

Posts: 265




Ignore
« Reply #32 on: September 25, 2008, 12:50:22 PM »

Thanks for your input Dave. For some reason I haven't seen or have overlooked all of your posts and
this is the first time I'm gotten any email from you. I am sorry for this.

I have tried Nova, Commander, Ham Radio Deluxe, SATpc32 and all others I could find and got
the same message trying to perform CAT control of my FT736, FT100D, and direct control of
my old FT757. The only thing I can get to work is rotor control using the LVB tracker box.

This problem is the same with both laptops. One is running XP pro and the other one is running
Vista. I know I'm doing something wrong, but I've tried so many different fixes that I no longer want
anything to do with rig control for satellites. I'll just do the doppler manually. I didn't need a rig
control program for anything but satellites anyway.

The trial version of Nova bombs both laptops and I have to remove power (and the battery) to
reboot. I don't believe Nova lets me get as far as opening the com port for CAT etc. so Nova might not be in this category

I am not a programer so your suggestion that I write my own driver etc. is not helpful to me.

Too bad that using a serial port is the only way to control radios. Maybe someday the radio designers
could design a way to do this like most other PC controlled appliances. I always thought of it as
a programing problem.

I get the message whether or not
there is a radio connected to the USB port via an adapter. If you have read all the previous posts you
know that I've tried just about all adapters on the market.

Regards,  Ken  K5MBV

Logged
AA6YQ
Member

Posts: 1648


WWW

Ignore
« Reply #33 on: September 25, 2008, 01:30:21 PM »

If you want to get to the bottom of this, install the latest release of Commander (via www.dxlabsuite.com) and then contact me via aa6yq@ambersoft.com - I'll be able to determine exactly what response Commander is getting from Windows when it attempts to open the specified serial port, and we can take it from there.

    73,

        Dave, AA6YQ
Logged
K5MBV
Member

Posts: 265




Ignore
« Reply #34 on: September 29, 2008, 04:31:31 PM »

Dave solved the com port problem. He had me to reload
Windows XP in the laptop not controlling the rotors,
This laptop was exhibiting other problems like locking up when trying to run just about any rig control software.

After I did this then installed Commander and the USB to serial driver, Commander opened up com port 4!

Unfortunatly my three rigs are FT-100D, FT-736R, and the old FT-757GX II. These don't respond well to CAT and other control. Sure enough the FT736 did light up the CAT LED, but I couldn't control it. Tried the FT-100D and it totally ignored commands. I think I need to load a different driver for it's serial to USB
cable and it should run. ...If I could just remember
which driver to load. I don't want top fill up all the
com ports again,

Can't thank Dave enough. He's a great guy and I really don't think the com port problem would ever been solved without his instructions over the phone.

Ken  K5MBV    
Logged
KE4DRN
Member

Posts: 3724




Ignore
« Reply #35 on: September 30, 2008, 06:03:49 AM »

hi Ken,

found this on another forum,

73 james

......................................................
If you go into the property of the USB defined Com Port you may be able to set what com port you want it to be defined as.

I only use Keyspan converters. I use them because they work with every software that I have thrown at them and they let me define the com port that they report to be and I can lock them so that no matter what USB port I plug them into I get the same com port definition.
Logged
Pages: Prev 1 2 [3]   Go Up
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!