Call Search
     

New to Ham Radio?
My Profile

Community
Articles
Forums
News
Reviews
Friends Remembered
Strays
Survey Question

Operating
Contesting
DX Cluster Spots
Propagation

Resources
Calendar
Classifieds
Ham Exams
Ham Links
List Archives
News Articles
Product Reviews
QSL Managers

Site Info
eHam Help (FAQ)
Support the site
The eHam Team
Advertising Info
Vision Statement
About eHam.net

donate to eham
   Home   Help Search  
Pages: [1]   Go Down
  Print  
Author Topic: Drake TR-7 display frozen on "51950"  (Read 2841 times)
KZ5Q
Member

Posts: 7




Ignore
« on: July 29, 2010, 05:34:59 PM »

Replaced the DR-7 board with a known working board...the display is frozen on "51950".  Transmit and receive work normally; EXT displays an external signal frequency as expected.  Any suggestions?
Logged
KZ5Q
Member

Posts: 7




Ignore
« Reply #1 on: July 30, 2010, 08:55:19 PM »

All is working now...had to drop the front panel and visually confirm pin engagement due to a warped chassis.
Logged
VE7YW
Member

Posts: 7




Ignore
« Reply #2 on: March 09, 2015, 02:05:25 AM »

All is working now...had to drop the front panel and visually confirm pin engagement due to a warped chassis.

My Drake TR-7 is now doing the same thing.  I was having a problem with the display on 10 meters and was told to ensure all the boards were snug.  I did, then rechecked them a 2nd time but this time I pulled the boards and cleaned the sockets and pins.  After reinstalling everything and turning the rig on, my display is now reading 51950 but I can still copy signals on all the bands.  What exactly did you find that cured your problem?

Terry
Logged
Pages: [1]   Go Up
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!