Call Search
     

New to Ham Radio?
My Profile

Community
Articles
Forums
News
Reviews
Friends Remembered
Strays
Survey Question

Operating
Contesting
DX Cluster Spots
Propagation

Resources
Calendar
Classifieds
Ham Exams
Ham Links
List Archives
News Articles
Product Reviews
QSL Managers

Site Info
eHam Help (FAQ)
Support the site
The eHam Team
Advertising Info
Vision Statement
About eHam.net

   Home   Help Search  
Pages: [1]   Go Down
  Print  
Author Topic: FLdigi, signalink and Ubuntu  (Read 7262 times)
G4GQL
Member

Posts: 52




Ignore
« on: January 01, 2012, 09:34:32 AM »

Hi all

Having used windows based digi modes, I have been trying Ubunto and FLdigi

Having set it up, it runs GREAT, but here are the questions

Does anyone know of a logging prog that will connect to eQSL.cc, or how to do it?

Also, does anyone know how to get the CAT to work, I have the RS232 to USB converter, but can't load a driver.
I have a driver disk for Linux, but do not understand how to load it, as all I get is a load of commands

Otherwise, I am finding this set up even better than windows set up as the Ubunto is simple and fast without annoying downloads

To recap...I need to be able to eLOG and run the CAT to my FT-817

Look fwd to any help

Alan
G4GQL



Logged
KB6HOH
Member

Posts: 189




Ignore
« Reply #1 on: January 02, 2012, 02:01:23 AM »

Alan,

       The latest version of FLdigi ver 3.21.33 does interface nicely with EQSL! Check it out.
Now I don't run Linux but there is a Yahoo User Group @ http://groups.yahoo.com/group/linuxham that you should join as well as the win-fldigi group @ http://groups.yahoo.com/group/win-fldigi

                                Good Luck and 73 de Steve KB6HOH
Logged
G4GQL
Member

Posts: 52




Ignore
« Reply #2 on: January 02, 2012, 08:11:33 AM »

Hi Steve
Thanks for reply, not sure how to activate eqsl in fldigi, would be very grateful for any tips,

I will check out your suggested web sites

Best regards
ALAN
G4GQL
Logged
WB0FDJ
Member

Posts: 144




Ignore
« Reply #3 on: January 02, 2012, 04:34:10 PM »

Alan

I might be of some help. Be warned: I've learned most of what I know by breaking something and then fixing it later.  Grin

I run both my FT-897 and FT-817 through fldigi and Ubuntu. I have a Yaesu CAT control cable that I bought through eBay with the name "Maxton" on it. I know there are several places to get these but this one has worked and wasn't too awful expensive. One end is an 8 pin plug which mates with the matching accessory plug in the back of the rig and the other end is a USB connector. My experience was, plug it in and it works. In fldigi you go into rig control (I use Hamlib but there are other choices) and select your rig from a drop down menu. It will ask for the USB port and for me it's either dev/ttyUSB0 or dev/ttyUSB1. Since I use the SignaLink interface it shows up as an outboard USB audio card and has one of those ports. No drivers were needed with this.

In fldigi when you have some stations saved in the logbook, go to Logbook in the top menu, select ADIF and merge. This allow you to select the QSOs you want to save, hit OK and it saves the ADIF file to your computers hard drive. When you are in the eQSL website they have an area for uploading that is pretty much self explanatory. You select the ADIF file from your computer and the data is then uploaded to their server.

I hope this at least gets you started. If I can be of any help drop me an email and I'd be delighted to clarify anything I can.

Happy holidays and 73 from WB0FDJ Doc
Logged
K0JEG
Member

Posts: 665




Ignore
« Reply #4 on: January 02, 2012, 04:49:22 PM »

Most USB to serial converters show up as ttyUSB(x). After plugging in the adapter open a terminal. type "ls /dev/tty*" and you should see it. In fldigi's rig control screen, put the full path to the USB adapter (/dev/ttyUSB0). Remember that case counts, too.

I use Hamlib for rig control, it seems to be better supported. I've also noticed that if I disconnect/reconnect my adapter adds 1 to the ttyUSB number. this isn't a big deal for me, but if it becomes a problem for you there are fixes online that involve setting up udev rules.
Logged
G4GQL
Member

Posts: 52




Ignore
« Reply #5 on: January 03, 2012, 01:39:43 PM »

Hi Guys

To WB0FDJ, Thank you Doc!

I did what you said, found the port, set the baud rate to 4800 and using Rigcat....it works!

Thanks a lot for advice...off to set up eQSL now

Just a note, I can't get Hamlib to work, how have you set up the boxes? which ones have you ticked in Hamlib and Rigcat?

Happy New Year

To K0JEG
Many thanks for your valuable advice in helping to locate the port

73
de alan G4GQL
Logged
K0JEG
Member

Posts: 665




Ignore
« Reply #6 on: January 03, 2012, 01:49:30 PM »

In fldigi make sure you have the "use rigcat" checkbox unchecked and the "use hamlib" checked.

Depending on how you installed fldigi you might need to add the hamlib libraries. In software center or Synaptic, look for libhamlib. There's a lot of stuff there you don't necessarily need, but for sure on Ubuntu 10.04 you'll need libhamlib2 at a minimum. I'd also install libhamlib-utils and -doc if you're interested in using hamlib to control other devices (for example, Gnome Predict will control radios and az/el rotators for satellite operation).
Logged
WB0FDJ
Member

Posts: 144




Ignore
« Reply #7 on: January 03, 2012, 02:40:40 PM »

K0JEG hit the nail on the head.
I recently installed a new larger HD in the cheapo netbox that I use in the shack. Had to do some reinstalling and with Hamlib I forgot to install the libraries he refers to. A simple download fixed all that and it works well.
I think you'll enjoy using Ubuntu and the great ham software thats available. I own 6 computers (including the original Macintosh Color Classic with a "beefed up" motherboard) and none of them run Windows. Linux just works.

DOC
Logged
WS4E
Member

Posts: 223




Ignore
« Reply #8 on: January 04, 2012, 12:13:04 PM »

The best logging program on Linux by far is CQRlog, heck I wish it run on Windows so I could have it on my SDR computer.  Fldigi can connect to it as well.

http://www.cqrlog.com/
Logged
G4GQL
Member

Posts: 52




Ignore
« Reply #9 on: January 04, 2012, 12:55:31 PM »

Hi All

Certainly finding Ubuntu a real pleasure, free from the commercial rubbish in Windows, no ads, no viruses, just a great operating system

When I put it on my PC dual boot, I found that it dissabled the ability to restore my PC to factory, must have deleted some files, but what I will do is let Ubuntu wipe the drive and then reinstall itself alone.

Anyway, back to digi, thanks for the tip on CQRlog, I will have a look at this. I like eQSL because of the QSL cards-does CQRlog do this?

So far-everything in FLdigi is working FB

OK on the 6 computers, I have 2 desktop and 4 laptops, and mainly ran HRD in Windows on them, excellent set up, but I am getting hooked on this Linux Ubuntu thing

OK on the logging, I am playing with the set up ADIF, so should be up and running soon

Thanks agn for all the advice and gud DX in the New Year

I will keep checking the discussion

Alan
G4GQL
Logged
KB4MB
Member

Posts: 295




Ignore
« Reply #10 on: January 05, 2012, 01:33:06 PM »

CQRLog will upload to LOTW (as long as you have trusted qsl installed).  Then what I do is just take the log I uploaded to LOTW and go on the EQSL website and upload the same log.  No biggie.
Logged
G4GQL
Member

Posts: 52




Ignore
« Reply #11 on: January 07, 2012, 01:02:29 AM »

Hi All

Happy New year and gud DX to all

All is working now here and many thanks for all the  advice

I made a discovery:

If you load Ubuntu to run alongside Vista you cannot connect to the internet, it does not see your connection, so after many frustrating hours, I simply plugged in a USB wireless dongle and hey presto! problem solved

Does anyone know how to get the internal wireless card set up in Ubuntu?

Bye fer now es 73 de Alan, G4GQL



Logged
WB0FDJ
Member

Posts: 144




Ignore
« Reply #12 on: January 07, 2012, 11:20:07 AM »

Alan

Not sure if I have an answer so much as a comment.

I am still running Ubuntu 10.04 on the shack computer and on my little Acer netbook. Two different kinds of hardware and the Ubuntu default install found by wireless card with no help from me. Automagic as they say.

I dual boot Ubuntu on my Macbook Pro and just recently upgraded to the newest Ubuntu, what is it, 11.10? Suddenly it doesn't default to finding my wireless card. I'm in the middle of finding out what I am going to have to do but there is help if you go to the Ubuntu webpage. In their support area you can do a search (I ran something like "wireless not working") and it brought up some helpful info. As I recall I will have to go into terminal to find my wireless hardware info, which is easy. Then will have to reload the driver. The Ubuntu help page generally will walk you through the steps. I'm not near the laptop or I'd be more specific. If I get onto the laptop the weekend I'll pass along any new findings.

DOC
Logged
KB4MB
Member

Posts: 295




Ignore
« Reply #13 on: January 07, 2012, 01:24:21 PM »

Apparently, a lot of people are having issue with 11.10 and the 3.0 kernel.  I would recommend sticking to 11.04 unless have a need to be on 11.10...
Logged
G4GQL
Member

Posts: 52




Ignore
« Reply #14 on: January 08, 2012, 12:48:56 PM »

Hi all

Yes...there seems to be a few issues with 11.10, but I am running FB here now. I had no problems with XP prof and Ubuntu, only with Vista, but using the WLAN 11g dongle, I did not need any drivers, just went into System settings, then Network, then wireless and settings were there. Only issue I have at the moment is logging in FLdigi, I seem to upload doubles which eQSL rejects. Is there a set way to export fron FLdigi and import into eQSL without duplicate entries?

Thanks for all the comments and catch you all agn soon

73
Alan
G4GQL
Logged
Pages: [1]   Go Up
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!