Call Search
     

New to Ham Radio?
My Profile

Community
Articles
Forums
News
Reviews
Friends Remembered
Strays
Survey Question

Operating
Contesting
DX Cluster Spots
Propagation

Resources
Calendar
Classifieds
Ham Exams
Ham Links
List Archives
News Articles
Product Reviews
QSL Managers

Site Info
eHam Help (FAQ)
Support the site
The eHam Team
Advertising Info
Vision Statement
About eHam.net

   Home   Help Search  
Pages: [1]   Go Down
  Print  
Author Topic: Did I kill my FT270 battery?  (Read 593 times)
VA2FSQ
Member

Posts: 511




Ignore
« on: January 22, 2013, 09:51:58 PM »

Basically the battery on my Yaesu 2m rig was discharged about 7 months ago and yesterday I charged it.  The batteries read 6,8V before I put the charger on, I left it overnight, and the display said 11.7V.  Well the minute I disconnect the charger, the batteries drop to 7V again.
I guess the NI-CD batteries are shot.  Do I have any options besides buying replacements from Yaesu?

Thanks for any advice
You'd think they would have dumped the ni-cd barreries in this day and age.
Logged

VA2FSQ
VA2FSQ
Member

Posts: 511




Ignore
« Reply #1 on: January 22, 2013, 10:06:15 PM »

Never mind, it's a 7.2V battery....working fine now...
Logged

VA2FSQ
N6AJR
Member

Posts: 9910




Ignore
« Reply #2 on: January 23, 2013, 11:06:25 AM »

 I am glad some one else was up to my tricks... Smiley
Logged
VA2FSQ
Member

Posts: 511




Ignore
« Reply #3 on: January 23, 2013, 07:13:44 PM »

 Grin
Logged

VA2FSQ
Pages: [1]   Go Up
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!