Call Search
     

New to Ham Radio?
My Profile

Community
Articles
Forums
News
Reviews
Friends Remembered
Strays
Survey Question

Operating
Contesting
DX Cluster Spots
Propagation

Resources
Calendar
Classifieds
Ham Exams
Ham Links
List Archives
News Articles
Product Reviews
QSL Managers

Site Info
eHam Help (FAQ)
Support the site
The eHam Team
Advertising Info
Vision Statement
About eHam.net

   Home   Help Search  
Pages: [1]   Go Down
  Print  
Author Topic: how to get FLDIGI working with USB to serial adptr using Fedora 17 (?)  (Read 6202 times)
WD8OQX
Member

Posts: 45




Ignore
« on: May 19, 2013, 04:40:49 PM »

The USB adapter is a RT systems USB-63 recommended for the Kenwood TS-480sat. & from googling appears to be a FTDI (?) chipset.

I am trying to get FLDIGI to work with this hardware but so far, nothing works.
The H/W has been tested with M$-W7 & works fine, so H/W checks.

I tried all the ports listed in FLDIGI & made sure that the data rate was 9600 as the rig wants & set the stop bit to 1, also as it wants but the parity bit doesn't seem to have a setting in the software, it's supposed to be NONE.

What gives, won't the linux version of FLDIGI (not sure about the M$ version either) work with a USB - SERIAL cable?

Any help getting this resolved will be greatly appreciated!
Logged
K3DCW
Member

Posts: 196




Ignore
« Reply #1 on: May 20, 2013, 10:54:03 AM »

Fldigi is designed on Linux and works just fine with a USB-Serial adapter. The most common cause of this problem is that many distros do not include the user in the DIALOUT group, which is owned by root.  It isn't a Fldigi problem, it is a system security "feature".

The solution is simple: add yourself to the DIALOUT group, log out and then log back in, and you should be good to go.

I'm not sure exactly how to do that on Fedora 17, but a click google search shows this: http://docs.fedoraproject.org/en-US/Fedora/17/html/FreeIPA_Guide/user-groups.html which should get you started.


Hope this helps.

73

Dave
K3DCW
Logged

Hamming it up on OS X!
www.machamradio.com
WB0FDJ
Member

Posts: 143




Ignore
« Reply #2 on: May 20, 2013, 01:44:29 PM »

Dave is right, USB-Serial isn't usually the issue. The drivers are, IIRC, in the core. When I plugged in my USB-Serial cable with a Prolific chip to the Ubuntu distro, it worked right out of the box.

It sounds like it could be a permission problem (Dave addressed this) or with the setup of fldigi. I don't think fldigi is difficult to set up but spent an afternoon one time setting up my IC-703 before I realized I had mis-set the baud rate. It was an "Oh duh!" moment. Also some of rigs seem easier to get working under RigCAT and others with HamLib. You may wish to try either to see if one is "easier" to get going. Running under RigCAT requires downloading an .xml file for your rig, HamLib just requires that you have HamLib.

Good luck.

WB0FDJ Doc
Logged
WD8OQX
Member

Posts: 45




Ignore
« Reply #3 on: May 20, 2013, 01:52:02 PM »

I already have my user in the dialup & I already tried a few other security "tricks". So I really don't think it is security related.
I have been troubleshooting this & found that FTDI isn't loading the module for the driver. So, more likely it's a "no driver" issue.
I tied modprobe but it comes back with an error that the idVendor can't be found.
Logged
WD8OQX
Member

Posts: 45




Ignore
« Reply #4 on: May 20, 2013, 05:40:00 PM »

OK, solved it!

Needed to run this command:

modprobe ftdi_sio vendor=0x2100 product=0x9e58
Logged
K3DCW
Member

Posts: 196




Ignore
« Reply #5 on: May 21, 2013, 02:21:04 AM »

Glad to hear you got it working.

73

Dave
K3DCW
Logged

Hamming it up on OS X!
www.machamradio.com
Pages: [1]   Go Up
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!