Call Search
     

New to Ham Radio?
My Profile

Community
Articles
Forums
News
Reviews
Friends Remembered
Strays
Survey Question

Operating
Contesting
DX Cluster Spots
Propagation

Resources
Calendar
Classifieds
Ham Exams
Ham Links
List Archives
News Articles
Product Reviews
QSL Managers

Site Info
eHam Help (FAQ)
Support the site
The eHam Team
Advertising Info
Vision Statement
About eHam.net

   Home   Help Search  
Pages: [1]   Go Down
  Print  
Author Topic: B&K 1570 CH1 vertical adjustment seems to be stuck in X5 Mode  (Read 1611 times)
N9XTF
Member

Posts: 227




Ignore
« on: March 18, 2014, 12:33:22 PM »

I just purchased a brand new, in the box, B&K 1570 70MHz scope. A local electronics store is going out of business and I found it on a back shelf. I made a low ball offer and they accepted (win win).

 Everything works as expected for the exception of Channel 1. When I test a voltage with this channel it is real close to 5X higher than it should. Channel 2 reads as it should. When I did some checking, pulling the vertical position knob, which should give 5X gain, has no effect whichever position it is in. I took the scope out of the case hoping that the pot / switch had a simple issue but it did not. I also disconnected the molex connector from the board, but there was no corrosion or other simple issue.

 I called Dynascan, they do not have a service manual for free, they directed me to a site that offers it for $65.00. I did not pay much more than that for the scope and seems extremely silly to buy it. I was not able to garner any other information from the web. Does anyone have an idea of where the problem might lie or where I might find a service manual for this animal?

 Thanks,

 Doug - N9XTF
Logged
Pages: [1]   Go Up
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!