eHam.net - Amateur Radio (Ham Radio) Community

Call Search
     

New to Ham Radio?
My Profile

Community
Articles
Forums
News
Reviews
Friends Remembered
Strays
Survey Question

Operating
Contesting
DX Cluster Spots
Propagation

Resources
Calendar
Classifieds
Ham Exams
Ham Links
List Archives
News Articles
Product Reviews
QSL Managers

Site Info
eHam Help (FAQ)
Support the site
The eHam Team
Advertising Info
Vision Statement
About eHam.net


Reviews Categories | Transceivers: VHF/UHF+ Amateur Base/Mobile (non hand-held) | Icom IC-821 Help


Reviews Summary for Icom IC-821
Icom IC-821 Reviews: 15 Average rating: 3.7/5 MSRP: $2000
Description: uhf/vhf allmode
Product is not in production.
More info: http://
Email Subscription
You are not subscribed to this review.

Subscribe!
My Subscriptions
Subscriptions Help

You can write your own review of the Icom IC-821.

<— Page 2 of 2

K4TB Rating: 4/5 Feb 19, 2003 23:14 Send this review to a friend
Good satellite rig  Time owned: more than 12 months
I thought I did this review earlier, and a follow-up? I don't see either on eHam anymore, so here's another, updated review, with some pointers.

My rig has performed well for 5 years or more. It does the job on satellites, and works fine for LOS SSB, CW and FM. It has plenty of sensitivity and good selectivity, with the optional CW filters I have installed in both the main and sub receivers. The operation takes a bit of practice but isn't that hard to master.

Incidentally, for those who have ever experienced the strange mode changes, etc., here's the cure: I found that the large connector on the main board, which you have to disconnect to install options like the CTCSS board, filters, etc., occassionally needs cleaning! Disconnect it by pulling up on the connector socket, then take a pencil eraser and easily brush off the copper contacts at the end of the ribbon. Reconnect the ribbon cable into the socket, taking care to seat it solidly, and you'll be back in business. I've had this problem recur about once a year. Guess ICOM could have done a bit better on that one, but what the heck, it's as good a rig as you can find for satellites, the FT847 notwithstanding.
 
K9PO Rating: 0/5 Jan 30, 2003 13:21 Send this review to a friend
A A boat anchor in the making  Time owned: 0 to 3 months
Terrible radio!!

Poor receive quality. The VCO had a tremendous amount of noise that would wipe many a weak signal out of the pass band.

The uP and software had some kind of serious problem where the radio would lockup or go into strange modes without any warning, explination, nor solution. Eventually it would fix itself but I could never figure a key sequence or procedure that would cause it to self repair. The only I can guess at is that their was some sort of watch dog procdeure in the software itself.

The radio was checked out by AES technicians but they could never find out what was happening.

I sold it for scrap and consider my experience a hard and expensive lesson learned.

 
DF1AS Rating: 5/5 Jan 25, 2003 20:06 Send this review to a friend
One problem within five years ...  Time owned: more than 12 months
I owned one for more than 5 years. Had it equipped with both CW filters and the TCXO. Also had set it to work outside bands, so transverters could be attached easily. Worked almost w/o problems. Just once after apr. 1 year it felt sick and started to act up (confusing numbers on the display a.s.o.). But, after demating, cleaning, and remating of all internal flat ribbon cables it ran smooth until I sold it (for quite a good price) to change for the 910.
 
IZ6BYY Rating: 5/5 Sep 1, 2002 04:16 Send this review to a friend
love it  Time owned: more than 12 months
I use it for satellite operations and never had any problem.
Receiver is wonderful, human interface is very usable after you get used to it.
Now I remote control this radio by the ci-v interface over the internet. THe radio is permanently turned on and still no problems at all.
 
PE3HMP Rating: 1/5 Sep 9, 2001 12:17 Send this review to a friend
lots of trouble  Time owned: 3 to 6 months
I have had 2 icom IC-821H trancievers both with major problems on 70cm
the first (serial number 2230) gave strange trouble,after a few hours (packet 9k6) the center lights would turn orange and would have no power on 70cm, on 2 meters it sends on a different freq and when switching to ssb if still recieves on fm, the dealer couldn't find it and it had to be send back to icom, I was not planning to wait months untill it got back so I bought a new one (serial 2231)(had to pay 250 extra)
After a few months the power on 70 had problems, while transmitting it stoped for a few mSeconds (noticeble as a crackle by other listners and you could see it on the S-meter)

Dealer could not correct the problem so I asked my money back.

NEVER an icom 821H for me again!!

PS: for people who suddenly have no outputt on 70 check Q43 !!! (that smd thing gets too hot !! and Icom knows that, just replace it with a non smd part)
 
<— Page 2 of 2


If you have any questions, problems, or suggestions about Reviews, please email your Reviews Manager.