eHam.net - Amateur Radio (Ham Radio) Community

Call Search
     

New to Ham Radio?
My Profile

Community
Articles
Forums
News
Reviews
Friends Remembered
Strays
Survey Question

Operating
Contesting
DX Cluster Spots
Propagation

Resources
Calendar
Classifieds
Ham Exams
Ham Links
List Archives
News Articles
Product Reviews
QSL Managers

Site Info
eHam Help (FAQ)
Support the site
The eHam Team
Advertising Info
Vision Statement
About eHam.net


Reviews Categories | Amateur Radio Equipment Repair | Kenwood Repair Service Help


Reviews Summary for Kenwood Repair Service
Kenwood Repair Service Reviews: 45 Average rating: 2.9/5 MSRP: $(missing—add MSRP)
Description: Kenwood factory repairs
Product is in production.
More info: http://www.kenwood.net/contact.cfm
Email Subscription
You are not subscribed to this review.

Subscribe!
My Subscriptions
Subscriptions Help

You can write your own review of the Kenwood Repair Service.

Page 1 of 5 —>

K3NRX Rating: 1/5 Mar 12, 2015 07:04 Send this review to a friend
Vintage Rig?..Don't Waste Your Time....  Time owned: more than 12 months
I had the "dots" problem with my TS-440 back in 2000...Sent to Virginia...was fixed and worked perfectly....Now my 440 needs repair again, here in 2015...and all Kenwood Service Centers will not repair it....This is most aggravating that I now have to send my radio all the way to California to a certified tech for repair, when I could send it to Virginia, closer to me...I also find it aggravating that the Kenwood Service Centers would service vintage stereo equipment from the 1970s and 1980s, but won't service one of their ham rigs from the late 1980s....Very disappointing, Kenwood...I pray my radio makes it to CA and back safely...As Kenwood is causing me shipping anxiety over this long trip, and I will be on pins and needles until it returns safely....Be advised...if you have a vintage kenwood solid state rig that needs fixing, don't waste your time with JVC/Kenwood Service Center.....
 
KB2MS Rating: 0/5 Feb 18, 2015 04:50 Send this review to a friend
Poor at best!!!  Time owned: 0 to 3 months
I have a new 480hx purchased in Nov, 2014 a ssb 1.8 filter was installed the end of Nov. The radio would not recognize the filter. The filter board was taken out and placed in another 480hx. That radio recognized it immediately. Therefore I was led to believe that there was a problem with the radio. Since the radio was brand new the dealer was kind enough to send it back for me to Kenwood East for repair. TheY received the radio 3rd week in Dec. I tried to find out some info on the radio, but was told since the dealer sent it back only they could question its status. The dealer called them about 2 wks later and he was told that there were some parts missing and they were waiting for the parts from Japan. Another week went by and I called my dealer and he gave me the name of a contact person in Virginia (kenwood east)to call for updates. I called and was told about the same as the dearler was told, waiting for parts. After about a month or more I called back and the contact told me they were shipping the radio now to California as their "top tech" was there. So now the radio was sent to California. I contacted Kenwood in California and was told the radio was going to be there on Feb. 5. I called again to remind them that the filter was good, don't waste time with that look aT something else. I was told a few days later that they were going to change the filter to check it, and I needed to send the invoice for the radio, as well as the filter invoice. More rederick. I called and emails were exchanged and on Feb 10 was told oh yes the filter was good. I had told them that at least 5 times to Virgina and now to California. On feb 12 they told me it was repaired and being sent bact to me. It came yesterday, ups no signature required and left at my door very late about 6pm. I found it when I left the house this morning. I couldn't wait to see the invoice on the problem. I opened the box in looked for the invoice. "R19 in final stage cold solder joint". Nice to know that 1 a new radio had a cold solder joint, but number 2 it took 7 WEEKS to find and repair it. They are truly neglegent in many aspects of customer service and their ability to find and repair a cold solder joint. AWFUL EXPERIENCE.!!!
 
N6HK Rating: 5/5 Aug 9, 2014 20:58 Send this review to a friend
Very good service.  Time owned: more than 12 months
Shipped my TS-590S to the FTH Group Inc., Kenwood's authorized factory repair facility. The problem I was having with the radio was no rf output and weak receive.

Via their Website, I was able to see exactly when my unit was received. In addition, I was able to track how my repairs were progressing.

I can say that from start to finish, including shipping the rig back, was handled with courtesy and professionalism.
 
N7FFO Rating: 0/5 Feb 3, 2014 14:03 Send this review to a friend
Won't fix older transceivers  Time owned: 0 to 3 months
After email communication with Kenwood Customer Service, I was advised to send my TS-50S to the Kenwood Service Center. They refused to repair it, saying it was out of production, and they couldn't find parts. This after being advised to send the radio in by Kenwood's own tech support. I'm out $45 shipping fees to and from with nothing to show for it. This is very frustrating.
 
G7UZN Rating: 5/5 Jul 21, 2013 12:00 Send this review to a friend
10 out of 10  Time owned: more than 12 months
I have a TM-D710 where the ceramic filters started to fail (faulty batch) I returned it to Kenwood UK......The filters were replaced and returned within 3 days free of charge. Now you can't argue with that.
FANTASTIC
 
N0SIB Rating: 5/5 Mar 23, 2013 10:44 Send this review to a friend
tech support   Time owned: 6 to 12 months
I have used the tech support a couple of times on older, out of production rigs and everytime, they have been just great. I wish every company had such great people and the willingness to help out. They've been kind and shown me were to turn to for parts or help if they have not been able to do it. I have delt with many companies on tech support over many years of working and there's is the best. GREAT JOB GUYS.
 
AA7QK Rating: 5/5 Jan 20, 2013 04:38 Send this review to a friend
Outstanding Service  Time owned: more than 12 months
I shipped my TS-2000 to the Kenwood Service Center on Jan 7 and received it back on Jan 17, 2013 - a 10 day turn around. The problems were repaired and the rig performs like new again. Their website allowed me to track the repair progress and even showed the UPS # to track the trip home. This as been a friendly and positive experience - way beyond my expectations.

It appears to me that Kenwood has addressed whatever past problems they may have had and have taken steps to now provide first class service for their amateur radio products.

My thanks and appreciation to Kenwood
 
KY6R Rating: 5/5 Jul 2, 2012 10:00 Send this review to a friend
FTH Group  Time owned: more than 12 months
Roy Pace and his crew did a great job with my Kenwood gear. They were in the middle of moving their office - but still turned the radio around in just over two weeks. I did like how I could track the progress of the repair on their web site - and when I called for a status they were courteous and professional.
 
WA6MOW Rating: 5/5 Nov 14, 2011 19:45 Send this review to a friend
Rapid Repair and Turn Around  Time owned: 0 to 3 months
Seven days from the time I shipped my TS-590 to S. Calif for repair I had it back in perfect working order. What more could I possibly ask for?
 
AF4KK Rating: 5/5 Oct 6, 2011 01:22 Send this review to a friend
A 1-week turn-around time!!  Time owned: 0 to 3 months
The Kenwood service center in Virginia was absolutely the best! I had my Kenwood 480SAT back in A WEEK and it now works perfectly! In addition, the staff was courteous and very helpful when checking on the status of my radio! Thank you, Kenwood for GREAT customer service!!
 
Page 1 of 5 —>


If you have any questions, problems, or suggestions about Reviews, please email your Reviews Manager.