eHam.net - Amateur Radio (Ham Radio) Community

Call Search
     

New to Ham Radio?
My Profile

Community
Articles
Forums
News
Reviews
Friends Remembered
Strays
Survey Question

Operating
Contesting
DX Cluster Spots
Propagation

Resources
Calendar
Classifieds
Ham Exams
Ham Links
List Archives
News Articles
Product Reviews
QSL Managers

Site Info
eHam Help (FAQ)
Support the site
The eHam Team
Advertising Info
Vision Statement
About eHam.net


Categories | Amplifiers: RF Power - HF & HF+6M | OM Power OM3500HF Help

Show all reviews of the OM Power OM3500HF

You can write your own review of the OM Power OM3500HF.

A41MO  Rating: 3/5 May 9, 2013 07:17  Send this review to a friend!
I beg to differ  Time owned: more than 12 months
This amplifier is fine, when working with a decent output; however, I have a story to tell:
Back in June 2009, I decided to bite the bullet and buy this amplifier. I had to budget for the cost of the unit and the cost of shipment. I received unit 0919 in August 2009.
The OM Power 3500 HF arrived well packed, but DOA (dead on arrival). I was lucky to have a visiting first rate Dutch technician; who opened it and verified that soldering the final wire to the on – off switch was on the wire plastic sheath. There were multiple pieces of bare wires, soldering wire and debris inside in the cabinet which was really terrifying to see. We informed Mr. Tibi, and then proceeded to clean the amplifier, we made sure the soldering was right, and switched on. It worked but the devil was in tuning it. Anything above 600-800 watts output while tuning will trip the amplifier.
To cut a long story short, the majority of the internal components were replaced by high quality, high tolerance components from the Netherland. It was all in discussion with Mr. Tibi, after trying to eliminate and narrow down fault, after fault, after fault.
The amplifier worked for a few weeks. Then one night, while on 20 m SSB, in a conversation with a normal recommended drive to generate 1500W no more, into a 20M M2 monobander; that never exhibited an SWR above 1:1 on most of the 20 meter band, the amplifier died a horrible death with a very big bang. Thankfully, there was no damage to the surrounding and no fire.
Photos, emails, telephone conversations, went back and forth before we shipped the unit back to the factory. Only then did Mr. Tibi acknowledge that it was a defective unit and offered to PART-EXCHANGE it!
As beggars can’t be choosers, outside the western hemisphere, I had to part with more cash for a replacement and pay yet again for a third round of shipment costs, which is usually borne by the factory, had one lived in the ‘right’ area.
The second unit arrived and worked for a few months without problems. Sadly, I started receiving alerts, by other stations, that there were significant fluctuations in my signal strength. The output power level was intermittent and temperamental. After many emails, messages and telephone conversations, a relay was sent via regular post, which naturally took a very long time to arrive / try.
Since replacing the relay, the unit is functioning OK; but quite honestly, I do not know for how long.
Although I have tried hard not to be paranoid, I cannot help but think that quality control, for us folk living in the ‘wrong’ areas, on units shipped to us, is a luxury, not a requirement. However, if you are buying this from the comfort of Europe or the United States, I suspect you will be just fine; after all, it is a good amplifier…when it works.
 
Product is in production.
Email Subscription
You are not subscribed to this review.

Subscribe!
My Subscriptions
Subscriptions Help


If you have any questions, problems, or suggestions about Reviews please email your Reviews Manager