eHam.net - Amateur Radio (Ham Radio) Community

Call Search
     

New to Ham Radio?
My Profile

Community
Articles
Forums
News
Reviews
Friends Remembered
Strays
Survey Question

Operating
Contesting
DX Cluster Spots
Propagation

Resources
Calendar
Classifieds
Ham Exams
Ham Links
List Archives
News Articles
Product Reviews
QSL Managers

Site Info
eHam Help (FAQ)
Support the site
The eHam Team
Advertising Info
Vision Statement
About eHam.net


Categories | Amateur Radio Equipment Repair | Ten-Tec Factory Repair Help

Show all reviews of the Ten-Tec Factory Repair

You can write your own review of the Ten-Tec Factory Repair.

AA4XE  Rating: 5/5 Aug 21, 2013 13:00  Send this review to a friend!
Fast and complete  Time owned: more than 12 months
My Omni VII had some issues with the ALC indicator LED and adjustment for the mike gain. I called Ten Tec repair and told them what I was experiencing. Gary, repair technician, asked me to send it in to be checked out. I did, although I had no backup radio.

It arrived at Ten Tec and they sent an email acknowledging receipt, and two days later, said it was repaired and completely checked out and was being returned,

It was completely like new - or better.

Excellent service, and good price as well. I lived with a deficiency for nearly a year; should have sent it in sooner. 
Product is in production.
Email Subscription
You are not subscribed to this review.

Subscribe!
My Subscriptions
Subscriptions Help


If you have any questions, problems, or suggestions about Reviews please email your Reviews Manager