Call Search
     

New to Ham Radio?
My Profile

Community
Articles
Forums
News
Reviews
Friends Remembered
Strays
Survey Question

Operating
Contesting
DX Cluster Spots
Propagation

Resources
Calendar
Classifieds
Ham Exams
Ham Links
List Archives
News Articles
Product Reviews
QSL Managers

Site Info
eHam Help (FAQ)
Support the site
The eHam Team
Advertising Info
Vision Statement
About eHam.net

donate to eham
   Home   Help Search  
Pages: [1]   Go Down
  Print  
Author Topic: IC-7610 Progressive Drive Loss Demonstration  (Read 416 times)
VK3BL
Member

Posts: 1357


WWW

Ignore
« on: December 01, 2017, 01:37:49 AM »

Hey Everyone,

Just wanted to say that Marty from Icom Australia has been absolutely fantastic, and arranged to lend me their unit whilst they do a full root cause analysis on mine to ensure its an isolated incident Smiley

One thing I found amazing in this day and age is they didn't demand anything in return; they didn't ask me to say nice things, or to not talk about the failure, etc.  They lent me their unit with 100%, absolutely no conditions.

To honour that kind of transparency, and their commitment to finding out what caused the fault, I've decided I'll post my video demonstration of the issue.

Here it is: https://www.youtube.com/watch?v=j2_Ou10qv0Q

Once again, thank you so much to Icom Australia for arranging a Loan unit, for taking the time to fully check mine out and ensure ongoing product quality, and for not asking me to compromise my integrity in any way whatsoever.
Logged

J.D. Mitchell - VK3BL / XU7AGA - http://vk3bl.wordpress.com
Pages: [1]   Go Up
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!