Call Search
     

New to Ham Radio?
My Profile

Community
Articles
Forums
News
Reviews
Friends Remembered
Strays
Survey Question

Operating
Contesting
DX Cluster Spots
Propagation

Resources
Calendar
Classifieds
Ham Exams
Ham Links
List Archives
News Articles
Product Reviews
QSL Managers

Site Info
eHam Help (FAQ)
Support the site
The eHam Team
Advertising Info
Vision Statement
About eHam.net

donate to eham
   Home   Help Search  
Pages: [1]   Go Down
  Print  
Author Topic: Tired of logging in on eHam  (Read 924 times)
K4SAV
Member

Posts: 2403




Ignore
« on: December 02, 2017, 02:37:04 PM »

EHam won't remember me.  I have to log in every time.  I am using Firefox 57.  I have cookies always enabled for eham.  This same version of Firefox works OK on QRZ.  Chrome works OK on eHam.  Only Firefox on eHam has the problem.  Help.

I tried deleting the cookies and letting eHam reinstall them, but that was no help.

Jerry, K4SAV
Logged
KM1H
Member

Posts: 2593




Ignore
« Reply #1 on: December 02, 2017, 06:15:34 PM »

Jerry,

If not a setup option in Firefox then maybe something set wrong in an AV or other security program?

My son has FF on his PC and I can look at it tomorrow; off to bed shortly  Shocked

Carl
Logged
G8YMW
Member

Posts: 661




Ignore
« Reply #2 on: December 03, 2017, 05:28:56 AM »

No problem here
Logged

73 de Tony
Windows 10:  Making me profane since March 2017
VA3VF
Member

Posts: 916




Ignore
« Reply #3 on: December 03, 2017, 08:04:53 AM »

The only anomaly I see sometimes, but has been happening over many Firefox versions, is that when I click to mark all threads/forums as read, it does not.
Logged
K4SAV
Member

Posts: 2403




Ignore
« Reply #4 on: December 03, 2017, 09:13:03 AM »

I got eHam to remember me by manipulating the settings under: Privacy / History.

I changed these:
Accept third party cookies
Keep until

Then eHam started remembering me.  Then I tried to figure out which settings caused the problem, but I couldn't find it.  Then I went back to the same settings I had before (which didn't work) and now those settings work.  Seems to be some kind of problem with the newest version of Firefox.  Earlier versions worked OK and when the newest version was installed, it picked up the settings that were there before, and displayed them correctly, but apparently did something weird with them.

I had previously changed:
Accept cookies from websites: Exception eHam: Allow
but that made no difference. 
Apparently the problem is associated with "Accept third party cookies" and "Keep until", but after manipulating these once, any settings of those now work OK.  Sounds like a programming error in Firefox 57.

Jerry, K4SAV
Logged
G4AON
Member

Posts: 1027




Ignore
« Reply #5 on: December 03, 2017, 10:38:21 AM »

No issue with the eHam site, works on latest Firefox (57?) under Win 10/64 Creators Edition and also with Safari on an iPhone with iOS 11. The cookies remain from ages ago, no problem.

73 Dave
Logged
K4SAV
Member

Posts: 2403




Ignore
« Reply #6 on: December 03, 2017, 02:58:01 PM »

Further experimenting has shown that the condition of eHam not recognizing me can be caused by running an older version of Firefox while version 57 is installed and is the default program.  I think I ran a game which runs under Firefox and that game booted the old version.  That's when the problem begins.  Installment of version 57 did not delete the old version.

To cure the problem, as stated above, you have to change the settings for "Accept third party cookies" and "Keep until".  Doesn't matter what you change them to.  Then restart Firefox and change them back to whatever you had before.

Jerry, K4SAV
Logged
Pages: [1]   Go Up
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!