Call Search
     

New to Ham Radio?
My Profile

Community
Articles
Forums
News
Reviews
Friends Remembered
Strays
Survey Question

Operating
Contesting
DX Cluster Spots
Propagation

Resources
Calendar
Classifieds
Ham Exams
Ham Links
List Archives
News Articles
Product Reviews
QSL Managers

Site Info
eHam Help (FAQ)
Support the site
The eHam Team
Advertising Info
Vision Statement
About eHam.net

donate to eham
   Home   Help Search  
Pages: Prev 1 ... 4 5 6 7 8 [9] 10 Next   Go Down
  Print  
Author Topic: LIDO MOUNTS  (Read 232569 times)
KD0TNH
Member

Posts: 3




Ignore
« Reply #120 on: December 18, 2013, 08:15:05 AM »

Don't purchase from this deadbeat outfit.  I just contested the charge.

Like others, I learned my lesson and will always check eHam reviews before ordering ham gear from companies that I haven't dealt with before.
No reply to multiple voicemails or emails.   Charged me immediately.  Their website generates no confirmation emails, so you have no idea if they got the order or when you might recieve it.

-Jeff

Logged
VE7MKD
Member

Posts: 2




Ignore
« Reply #121 on: December 18, 2013, 02:31:00 PM »

Same thing here...I made two separated orders one came and the other was not filled. Oh they did send me something that I didn't order. After talking to Jim Newcomb. He said he would send up something else that I would be happy with. This was over 4 weeks ago now. Still nothing and no answer when I phone. I even gave them a list of another mount to send me to call it square. Nothing. So all I can say is buy your mounts else where.
Logged
KF7TNN
Member

Posts: 2




Ignore
« Reply #122 on: February 05, 2014, 11:47:48 AM »


Sadly, I too found this thread after making the purchase directly with Lido Mounts. I purchased my mount 2 weeks ago and received an order confirmation, my credit card was charged, but received nothing regarding the product actually being shipped. In an effort to follow up on this I emailed Jim earlier today to see what the deal was. I wasn't expecting a super quick reply, and in fact if he just got back with me in the next day or so that that would be cool. However, in the meantime I ran across this thread and now I'm thinking to myself "don't hold your breath". I have no idea if I will ever receive the mount, or even a reply for that matter...but what I do know is that I've now ordered the same mount from HRO and will have it tomorrow. Something I should have just done in the first place!

Logged
KA5IPF
Member

Posts: 1407


WWW

Ignore
« Reply #123 on: February 05, 2014, 10:28:56 PM »

Like everyone else, dispute the charge on your credit card and get a refund.
Logged
KF7TNN
Member

Posts: 2




Ignore
« Reply #124 on: February 10, 2014, 11:16:59 AM »

Quick update:  I did end up receiving my mount a few days after I posted here. However, I still never received a return phone call or a reply to my emails. Also, there was a small piece broken on the top of the mount, but since I had already received the second mount through HRO I am not going to waste anymore time trying to get it replaced. At the end of the day it's a nice mount, but I would still only recommend purchasing it through a distributor such as HRO, HamCity, etc. just due to the lack of response and customer service when dealing directly with Lido Mounts.
Logged
W5NDC
Member

Posts: 7




Ignore
« Reply #125 on: January 09, 2015, 04:20:37 PM »

Well I see this thread was started in 2006 and here we are 9 years ago and it seems I found my way to this thread as a possible victim. I ordered my mount on Jan 2nd and on Jan 3rd received a tracking number from stamps.com of all places which doesn't seem very professional to me. Anyways, it was priority mail so 1-3 day turn around. I have a order off eBay that came from Taiwan in less time even going through customs. I was expected to receive my mount on Jan 6th and here it is Jan 9th and no mount and the tracking info has not been updated. Called USPS and they stated they were notified for pickup but no pickup was made which explained why there was no tracking updates. I tried to call but the number on the web site and other numbers I have seen on here are disconnected. So I sent an email early this morning and no response as of yet. If I don't receive a response by Monday I am going to file a charge back based on the findings of this thread since it seems I probably won't see my mount and I was really hoping to have it by this weekend so I could do my mobile install since I am dead in the water without it. Looks like I am not going to be able to do that now.
Logged
WI8P
Member

Posts: 604




Ignore
« Reply #126 on: January 10, 2015, 11:10:31 AM »

Well I see this thread was started in 2006 and here we are 9 years ago and it seems I found my way to this thread as a possible victim.

Part of your problem may be your clock is running backward.  Grin   Grin   Grin
Logged
W5NDC
Member

Posts: 7




Ignore
« Reply #127 on: January 12, 2015, 07:42:52 AM »

Part of your problem may be your clock is running backward.  Grin   Grin   Grin

HA!  Grin It took me a couple reads to get that even when you made it bold. Sorry, that was suppose to says 9 years later. That's how irradiated I was. Ha!

Well an update, after what I read here I went to PayPal since I paid for it through PayPal and I didn't have much confidence based on what I had read on these posts that I pushed a dispute through PayPal. Wasn't even an hour after I pushed a message to him through PayPal that I got a shipping notification from USPS via text that they had picked up my package. Coincidence, I don't know but, it is rather amusing that once I took some sort of action outside of sending an email that it took starting a dispute through PayPal to get some action and my package shipped a hour later when my package was supposed to have been shipped a week ago when it said it had shipped. Not sure why he sent a tracking number a week before the item even shipped if it hadn't.  Anyways, I got it this morning and got it unboxed.

It is a shame that there was such a lack of communication and I had to resort to other measures to get it shipped. He stated he was a one man show and he was backed up. Ok understandable if that is the truth I will give him the benefit of the doubt but, a little communication goes a long way. Once I got it unboxed I inspected it and it seems to be a pretty solid mount and well built and very similar to a Ram Mount and will suit my needs perfectly. Only negative I see which could pose a problem in time is that the suction cup doesn't seem to be that strong and I could see that falling off often. Again, I haven't had much time to weight that possibility but, it is the one thing that stands out as I had a problem getting it to stick. If it becomes a problem I may get a Ram Mount suction cup to resolve that issue if it becomes one since it works just like a ram mount.

Logged
WB4EJZ
Member

Posts: 5




Ignore
« Reply #128 on: January 21, 2015, 06:01:59 PM »

Well, I did order a LIDO mount and received it in about a week, so I can't really complain. Other than sending an email to inquire about the ship status, I had no worries/problems.

73,
-Ken
WB4EJZ
Logged
N9PBD
Member

Posts: 1




Ignore
« Reply #129 on: September 10, 2015, 12:08:14 PM »

Why is it that we all find this thread AFTER we place an order with Lido?  I take responsibility for failing to do my homework before I placed my order, but good grief, he went to the trouble of processing the shipping label, but never put my package in the mail.  It's been three weeks for me, so I'm going the PayPal resolution route.  Wish me luck.

73, Greg
N9PBD
Logged
KG5RJS
Member

Posts: 15




Ignore
« Reply #130 on: February 28, 2016, 12:50:34 PM »

I just want to say, that after reading these reviews, I did actually order a vent mount for my IC-706 MKIIG, for $14.99.  I figured if I lose my $15 it won't be that big a problem.  I was curious about this company.

I'm happy to report that after about 2 weeks, I received the mount.  It's rock solid stable, good quality, and I'm thrilled, and surprised.  The company doesn't send a confirmation or shipping email, so that could be improved.  Anyway, at least from my one shopping experience, they seem to have their act together.

Shane KG5RJS
« Last Edit: February 28, 2016, 12:53:57 PM by KG5EIE » Logged
N1CZZ
Member

Posts: 3




Ignore
« Reply #131 on: April 22, 2016, 02:32:26 AM »

I just read many comments from 2009. Well, seven years later, received email stating they have shipped package, tracking number says pre shipment label info sent, 5 days later no updates on USPS, still says shipping/label info sent.  This is kinda nuts.  I received the initial email sooner than most companies, like in hours instead of a day, but then instead of it being shipped in a day, six days later still not shipped. It has to be the owner, because if it was an employee they would have been fired by now.
Logged
K1DA
Member

Posts: 724




Ignore
« Reply #132 on: October 23, 2016, 02:10:35 PM »

Just installed my Lido gooseneck and it's exactly what I needed.   Got it via DX Engineering.  They're usual prompt service.
Logged
W2TB
Member

Posts: 2




Ignore
« Reply #133 on: November 24, 2016, 05:45:14 AM »

Ordered direct from Lido website. Received an immediate email that my funds were deducted from my PayPal acct. After a couple days I requested a ship date and tracking number since I had asked for Priority shipping. No response. I called the company phone and left a message, leaving my name and phone asking for a return call. No response. Tried his personal email. No response. So, I opened up a complaint with PayPal and a week or two later my money was refunded. What a waste of time dealing with Lido Mounts.
I called HRO. Ordered the same mount and accessories and it was at my doorstep in two days, and the guy on the phone could not have been nicer.

I'm not going to pass judgement on the owner of Lido, as we all have our problems, but good grief, this was frustrating and aggravating. Save yourself the headache and go through anyone else but Lido.
Logged
K5SJW
Member

Posts: 1




Ignore
« Reply #134 on: December 11, 2016, 12:33:02 PM »

 Angry  Same here ordered on Dec 3rd  Got email confirmation that the order Label was printed 3 days days later  and USPS was waiting on package..  Still in that state today.. Company will not respond to emails and will not answer phone

Logged
Pages: Prev 1 ... 4 5 6 7 8 [9] 10 Next   Go Up
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!