Call Search
     

New to Ham Radio?
My Profile

Community
Articles
Forums
News
Reviews
Friends Remembered
Strays
Survey Question

Operating
Contesting
DX Cluster Spots
Propagation

Resources
Calendar
Classifieds
Ham Exams
Ham Links
List Archives
News Articles
Product Reviews
QSL Managers

Site Info
eHam Help (FAQ)
Support the site
The eHam Team
Advertising Info
Vision Statement
About eHam.net

donate to eham
   Home   Help Search  
Pages: Prev 1 ... 9 10 11 12 13 [14]   Go Down
  Print  
Author Topic: Ameritron ALS-500 / MFJ Quality Lacks  (Read 95061 times)
N4ATS
Member

Posts: 1197




Ignore
« Reply #195 on: October 12, 2012, 04:55:46 AM »

What we have been doing and is very effective in actually helping is when a person buys an MFJ / Ameritron amplifier . he has a free choice. They can bring it by my shop , I pop the covers , inspect / fix the obvious cold solder joints  (if any) check all the connections and power it up while they watch. I also give them a 2 minute loading course. I also offer for free the AC input selections if they need to change it as well as add a new plug that they supply. I have done quite a few like this and it gives the owner a feel that  "hey when I get it home it will work".  And NO this is not tagged to the store , its a free service Jim and I came up with before he passed away. When I get a bad or defective one , if its not too bad I fix it while they wait saving the return agony. Total time is about 15 minutes (less any repair work) and the owner walks away happy.

This invitation is open to all no matter where you bought it. A man from Melbourne brought one over last week.

« Last Edit: October 12, 2012, 05:30:13 AM by N4ATS » Logged
NN4X
Member

Posts: 51




Ignore
« Reply #196 on: October 19, 2012, 06:29:17 AM »

Yet another "troublemaker" just stone cold disrespecting MFJ!  It's a conspiracy, I tell you!

PA1ZP's discussion of MFJ - too funny

 http://www.eham.net/reviews/detail/10038   

73,
Steve
NN4X
Logged
MM0IMC
Member

Posts: 68




Ignore
« Reply #197 on: December 07, 2017, 10:49:43 AM »

I'm making this a Lazarus thread... Wink

I bought an Ameritron AL-811HXCE just over 5 years ago and traded it in against an Alpin 100 MK III.  I had some problems with the 811H, but looking back now, I put that down to user inexperience and some rather unrealistic expectations. I'm tempted to by another one because I actually like the simplicity, near enough instant-on and something that I could repair fairly easily, for the most part...

What would I do differently this time?  No high duty cycle modes like RTTY, SSTV, etc., just sticking to SSB. Avoid using it on 12m/10m totally and perhaps not on 15m either.

I think Tom pointed out elsewhere that the 811 and 811H amplifiers were at their maximum when ran at the power levels that Ameritron claimed. If both models were ran at 400W PEP and 600W PEP respectively, or less, I'm sure they'd last a lot longer.  Mind you, there's only so much that can be done with poor quality Chinese valves (tubes).  I've had 12 811A valves from China over the years and only one was a duffer.  I had 4 Chinese 572b valves and 1 was a duffer.  I think the 572b valves weren't as good, IMHO.

73,

Ian - MM0IMC.
Logged
Pages: Prev 1 ... 9 10 11 12 13 [14]   Go Up
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!