Call Search
     

New to Ham Radio?
My Profile

Community
Articles
Forums
News
Reviews
Friends Remembered
Strays
Survey Question

Operating
Contesting
DX Cluster Spots
Propagation

Resources
Calendar
Classifieds
Ham Exams
Ham Links
List Archives
News Articles
Product Reviews
QSL Managers

Site Info
eHam Help (FAQ)
Support the site
The eHam Team
Advertising Info
Vision Statement
About eHam.net

donate to eham
   Home   Help Search  
Pages: [1]   Go Down
  Print  
Author Topic: Getting a programming cable to work  (Read 3339 times)
N4KYW
Member

Posts: 146


WWW

Ignore
« on: March 18, 2018, 12:36:52 PM »

I have been trying to get an FTDI programming cable to work with Chirp. I downloaded and ran the (latest) software to install the drivers for this cable, though I never received confirmation that the installation was successful. I connected the free end of the programming cable to my rig (Jetstream JT270MH, powered on), opened Cirp, and attempted to download the current frequency chart. But I received an error message.
Is there something else I need to do to make it work? The default comm port in Chirp is COMM4. The programming cable plugs into a USB port, so I suspect that needs to change.
Thanks
Logged
AC7CW
Member

Posts: 1339




Ignore
« Reply #1 on: March 18, 2018, 05:46:45 PM »

FTDI chipset should plug and play fine on windows. You shouldn't have to download any drivers afaik.
Logged

Novice 1958, 20WPM Extra now... (and get off my lawn)
N1UKX
Member

Posts: 144




Ignore
« Reply #2 on: March 19, 2018, 05:13:35 AM »

When you plug the cable in, you then need to go into Device Manager, USB controllers and see what COM port windows assigned to the cable and change it in your program to that COM port.  There may be some other step, but that should get you started...
Logged
KG4RUL
Member

Posts: 3354


WWW

Ignore
« Reply #3 on: March 19, 2018, 09:11:39 AM »

The windows assigned comport and the software comport need to match.
Logged
KC9MGX
Member

Posts: 14




Ignore
« Reply #4 on: March 19, 2018, 09:22:40 AM »

My overall experience has been that when I buy a $5 cable online it requires lots of trial and error, and often plain doesn't work.

But when I buy a $20 cable from the manufacturer, it does work. So I'm convinced it's worth the trouble to buy the more expensive cable from the manufacturer, if that's an option.

Just something to consider.
Logged
N4KYW
Member

Posts: 146


WWW

Ignore
« Reply #5 on: March 23, 2018, 05:23:30 PM »

When you plug the cable in, you then need to go into Device Manager, USB controllers and see what COM port windows assigned to the cable and change it in your program to that COM port.  There may be some other step, but that should get you started...
The Device Manager is reporting COM5. However, I cannot locate anywhere in the program I am using,CHIRP, a place to set the COM port.
Logged
WA4BCS
Member

Posts: 45




Ignore
« Reply #6 on: March 23, 2018, 08:03:05 PM »

When you select Download from Radio a menu should pop up asking for Com port--you can change it, then it will ask about the radio and model.
Logged
NA4IT
Member

Posts: 186


WWW

Ignore
« Reply #7 on: March 24, 2018, 03:34:53 AM »

What we have here is a failure to communicate.... from the com port that is...
Logged
N4KYW
Member

Posts: 146


WWW

Ignore
« Reply #8 on: March 24, 2018, 11:26:43 AM »

What we have here is a failure to communicate.... from the com port that is...
I love it! Well, I identified the correct port as COM5. Then, in CHIRP I clicked on Radio > Download from Radio. Next I set the COM port to 5 and selected radio/model from the drop-down list: BTECH UV-25X2. Now I was able to do a Download from Radio, though I have no idea where the results went. But it appears the BTECH is communicating with my laptop. However, the option to "Upload to Radio" is still not selectable (activr). That's what I want to do in the first place... upload a CHIRP frequency chart to the radio.
BTW, I am using the very latest version of CHIRP (02/24/2018).
Logged
N4KYW
Member

Posts: 146


WWW

Ignore
« Reply #9 on: March 25, 2018, 04:03:12 PM »

A huge THANK YOU to everyone who responded. After two days of struggling I finally got the programming cable to work. Here are a few things I learned along the way:

1. Once the programming cable is plugged into a USB port of your computer, the COM Port number that Windows assigns may be found here: Control  Panel > Hardware and Sound > Devices and Printers > Device Manager. After clicking on Device Manager look for Ports (COM and LPT). Double-click on it. You should find an entry with terms like 'FTDI' and 'USB Serial Converter. The COM port number associated with this device is the one you should report in CHIRP.

2. Apparently, you cannot simply open up CHIRP, create a new frequency chart, save the chart, and expect to upload it to the radio. The reason is, a programming chart created this way is file type .csv. The radio doesn't understand .csv, only files of type .img (image). The way to obtain an .img file is to download it from the radio, using CHIRP. Once you've downloaded your radio's .img file, you can re-program the channels any way you like. Save a copy of the re-programmed .img file on your computer. Then you'll be able to upload it back to your radio.

3. In connection with all of this, a best practice is to power off your radio, connect the programming cable, then power your radio back on.

I'm exhausted from assimilating all of this, so I'm going to go QRT now and take a nap. 73
Logged
Pages: [1]   Go Up
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!