Call Search

New to Ham Radio?
My Profile

Friends Remembered
Survey Question

DX Cluster Spots

Ham Exams
Ham Links
List Archives
News Articles
Product Reviews
QSL Managers

Site Info
eHam Help (FAQ)
Support the site
The eHam Team
Advertising Info
Vision Statement

donate to eham
   Home   Help Search  
Pages: [1]   Go Down
Author Topic: Vexing USB to serial adapter problem  (Read 9052 times)

Posts: 4

« on: July 22, 2010, 05:53:30 AM »

Hello All-

I just switched to a new laptop for contesting and logging. A Lenovo with Vista Business installed. The machine is a hand me down as my preference would be for XP Pro so I'm just trying to get this to work for me without a complete reinstall of the OS.

My problem came last night getting ready for the NAQCC cw sprint. I'm using a Belkin USB to serial adapter. The drivers for the Belkin installed just fine and the belkin adapter is working FB with N1MM contest logging software.

When I tested the communication to the N1MM software everything was fine. It keyed my rig with perfect CW.

The problem came when I started to type in a call sign in N1MM's logging window, the computer sent a signal to the USB port/adapter with every press of the keyboard and it keyed my rigs in odd, garbled ways. I'm not hearing letters and numbers being keyed but just random long and short tones that do not make any sense. I quit N1MM and did some more typing - same thing. Every time I press a key on the laptop a strange signal gets sent to the USB port and it keys my rig in gibberish.

I am wondering if anyone has experienced this problem before and knows where to look for a solution. Is it the adapter, Vista Buisiness, or the Lenovo that is to blame? Maybe something else I am overlooking in the software??

Any hints would be great and save me hours of trouble shooting!

The hardware works perfectly on my old Sony laptop running XP Pro.

Posts: 2

« Reply #1 on: August 23, 2010, 04:58:30 PM »

This probably won't help, but did you try running the N1MM software in XP mode?  It's worth a shot.

Is there more than one USB port?  Have you tried using all of them?

Have you changed the COM port setting on the adapter?  There might be a problem with the keyboard and serial port trying to use the same COM port.

I guess the only other suggestion I'd have is to try a different serial adapter that uses a different chipset, or look around the internet for a different set of drivers.

Posts: 417

« Reply #2 on: August 23, 2010, 07:11:33 PM »

Although I don't have your exact hardware/software problem, it is very close to my vexing experience.

I presume that Belkin has a web-site from which you could download their latest driver for your device; if you've not yet done that, I say that's worth a try.

Suggestion#2: try some RFI snap-on cores on the cable just in case there is some RF trying to get you.

In my particular case, I had a Keyspan adapter that worked with XP but not with Vista, even though the driver for Vista was Microsoft certified.
After much wasted time, I bought a $40 adapter from Radio-Shack and it has worked flawlessly (BTW, without RFI snap-on cores).
So suggestion#3: buy the Gigaware adapter from Radio-Shack; if it does not work, you can return it within 30 days and get your $40 back.

73 Jerry KM3K

Posts: 14710

« Reply #3 on: August 23, 2010, 07:29:56 PM »

Belkin is pretty much the bottom of the heap. I'd upgrade to a better quality adapter, preferably something with an FTDI chip set in it. FTDI has Microsoft certified drivers available for all of the operating systems including Vista.

Bob  AA4PB
Garrisonville, VA

Posts: 77

« Reply #4 on: August 28, 2010, 11:34:49 AM »

I had a different problem with a Belkin USB to serial adapter.  Ham Radio Deluxe would run for about thirty seconds and then lock up.  After looking at everything related to the software and being unable to fix it, I empirically changed to a different adapter - which instantly solved the problem.

Something similar might be going on in your problem.  Maybe you can borrow another adapter from a friend to try before buying a new one?


Posts: 5058

« Reply #5 on: August 30, 2010, 03:36:26 PM »

I have Windows 7 -64 and use N1MM and HRD 5.0 with my FT-950 using this USB to serial adapter below:

My guess is that the Belkin is a problem with Vista. Before I purchased this adapter, I found that numerous adapters would not work with Vista and Windows 7. One that was recommended was Keyspan, and I verified beforehand that it would NOT work with Windows 7. There is a certain chipset that is a problem (I cannot recall the name).

The adapter above does in fact work with my laptop. Install the drivers BEFORE you connect the adapter. After install, plug the adapter and you are off and running.
« Last Edit: August 30, 2010, 03:39:04 PM by Vinnie Sallustio » Logged

Posts: 9

« Reply #6 on: September 03, 2010, 10:49:30 PM »

Please check out the drivers listed at the PROLIFIC site, they be a FIX.....
They work with al versions of the WINDOWS series O/S and MAC.
Pages: [1]   Go Up
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!