Call Search

New to Ham Radio?
My Profile

Friends Remembered
Survey Question

DX Cluster Spots

Ham Exams
Ham Links
List Archives
News Articles
Product Reviews
QSL Managers

Site Info
eHam Help (FAQ)
Support the site
The eHam Team
Advertising Info
Vision Statement

donate to eham
   Home   Help Search  
Pages: [1] 2 Next   Go Down
Author Topic: Echomac doesn't work  (Read 14469 times)

Posts: 74

« on: October 08, 2007, 03:46:49 PM »

Hi,  Unable to get echomac (echolink) to go beyond just listing the stations.  
So far:
I've tried 2 different Macs (newest version of System TIger) on more than a dozen different ISPs, both 802.11 wireless and hard wired and T1 with no results. UDP ports 5198 and 5199 are properly active under firewall of the router I use most of the time. Results: nil. On instances with a router, I established proper tunneling (Netopia calls it pinhole) of UDP 5198 5199 thru the router's firewall. Results: Nil

So far I've spent hours trying all sorts of combinations and settings trying PPOE, and absolutely nothing works.

Quote =AA4FX  "The application installed with no problems. Works well. No problems."

Sir, this is great for you.  May I ask, how did you get it to work?

The top message posted in the product review form states, "don't believe people who can't get it working."  Well please stand around and watch.  It does not work. Shall I make a video of it not working and post the video?  

Quote = MWILDING: "The solution: pick a machine, get its IP address and set up port forwarding on your router/bridge. "

What machine?
IP Address?  How?  With what?

QUOTE=Jim "I would check again that your router is correctly configured to forward UDP traffic on ports 5198 and 5199 to your Mac. "
I did.
Netopia, Expert Mode, Configure, Advanced, Pinholes,
Pinhole Name:Echomac1, UDP, Port Start 5198, Port End 5198, Internal IP Address;, Internal Port 5198, submit,
then the same procedure for 5199.
Submit, Restart, go back and it's still there.

QUOTE=Jim  "Simply making a hole is not enough.  It must reverse any network address translation it is doing. "

The pinhole is in place, but how do I do that the reverse NAT???

QUOTE=Jim "The EchoMac Help suggests using port triggering, because that is the most foolproof way of making sure you are forwarding to the right private IP address."

That's nice, but it fails to explain how to do it, it assumes the reader is proficient in port triggering.  

QUOTE=Jim  "If your router doesn't provide that feature, you will need to change the forwarding address each time you try a different computer on your LAN to make sure you are forwarding to the right private IP address."

What forwarding address and, how, specifically, do I do this?

I'm not trying to be disrespectful.  Congratulations to those who managed to get it to work.  I've spent a lot of long hours trying to troubleshoot EchoMac; there may be some elusive, missing steps that will make a difference.  Any clue as to what specifically makes it work will be much appreciated.  

Again, I mean no disrespect to anyone.


Posts: 47

« Reply #1 on: October 09, 2007, 09:04:35 AM »

My router logs show TCP port 5200 is also used. I would set your "pinhole" to allow TCP/UDP 5198 to 5200 and see if that fixes it.

Any clues in your router logs? (dropped/blocked IP/ports)
Firewall on the  computer you are using turned on? Try disabling it. It may need an exception added if it's the XP built-in firewall
and things work if it's turned off.

Lots of things can get in the way, depending on how your particular router and system are configured. Just takes time to poke at it until one of you gives up.

Good luck


Posts: 74

« Reply #2 on: October 09, 2007, 04:40:22 PM »

Hi Dick,
Thanks much for replying.
Yes 5200 pinhole TCP and 5198 also UDP.  Unable to access Netopia router log (if any).  Tried firewall off.  I don't use XP, I use System Tiger 10.4.6.

Here's what System Tiger's console log reveals:

2007-10-09 18:19:22.825 EchoMac[410] Error: echolinux exited with code 15
2007-10-09 18:19:40.903 EchoMac[410] Error: echolinux exited with code 15
2007-10-09 18:20:08.669 EchoMac[410] Error: echolinux exited with code 15
2007-10-09 18:20:57.747 EchoMac[410] Error: echolinux exited with code 15
(event handler):Object  (result of expression ValidateCall) does not allow calls.
(event handler):Object  (result of expression ValidateCall) does not allow calls.

Been trying lots of things, and lots of different hotel routers as i travel a lot (although I can't mess with those), and even some random wireless systems; so far, I can't get past just seeing the list of 3600 stations that are on the air.  Attempts to connect result in timeouts.

Thanks again for your thoughtful reply,

Posts: 9

« Reply #3 on: October 10, 2007, 10:39:16 AM »

Hi Jack, I had a very difficult time getting echomac to work on my computer also.  There is a help file in echomac that will help you with some of the settings on you computer, router, and modem .  What I found to be the biggest problem was my modem settings.  I don't have a router but my modem has settings like a router that took a lot of playing with to get right.  I was able to get echolink to work on my PC running XP but not on my Mac with OS 10.4.10.  I finally got the settings right and now I can use ether computer without any problems.  I had to call the modem manufacture and have them walk me through the steps several times.  I then figured out on my own how to get both computers to work.  I don't have a clue as to where you are with the entry of SCUBA.  If you want to email me directly I am good in QRZ maybe I can help you more.  
Al, n7ioh

Posts: 47

« Reply #4 on: October 11, 2007, 07:35:35 AM »

echolinux is telling you something is wrong, unfortunately in the typical cryptic way most error messages do, completely useless. A quick search  for exit code 15 did not give me a clue. Programmers may know it, I don't.

Do you have the latest EchoMac 1.16? Try deleting and emptying trash on the old application and preferences and reinstall.
has the latest. It's for both PPC and Intel Macs.
Also try repairing permissions (I know, it's silly)

Do you have the proper sound-in and out devices
selected in the Sound prefpane? (I doubt this is it)

Is the Mac Firewall On? Try off. (I doubt this is it)

That's all that comes to me for now, need more coffee...

Posts: 47

« Reply #5 on: October 11, 2007, 07:49:42 AM »

I guess exit code 15 could be your timeout

Too bad we can't see the verbose router logs.

Did you ever find port triggering on the router?
If so, you could try setting TCP/UDP 5198-5200 to trigger those same ports.

Did you set port forwarding in the router to point 5198-5200
at the IP of your Mac? If your Mac doesn't have a static IP
that wouldn't work unless you were lucky.
Set the Mac to a static IP (not DHCP) and update the router settings.

If any other silly ideas come to me, I'll pass them on until you
say enough.


Posts: 74

« Reply #6 on: October 13, 2007, 05:34:18 AM »

Hi N7IOH and WB6NGC,

Thanks much for your replies.

RE: The Netopia Router (Motorola), in their manual, regards "pinhole" to be "port forwarding."  W7IOH, I don't use the website login, "SCUBA," I use my real callsign and password as assigned.  Smiley

WB6NGC, I do have ver 1.16 running (not running), and firewall off, repaired permissions, performed all the diagnostics that the Onyx program provides.  I tried using windoze XP  under Parallels on the MacBook Pro with Echolink, and experienced the same problem.

I travel a lot, so I tried numerous hotel routers (hard wired and wireless) with the same problem, although Jim advised that hotel routers typically forbid any kind of port forwarding.

Sound functionality is normal on both Macs

Coffee - Yes

Getting a router log out of a netopia router is elusive; setting it up to provide a log is a "no go" so far.   Guess I need to go to the CCNA course in Idaho.

Port forwarding UDP 5198 5199, yes, Netopia calls it pinholes; TCP 5200 yes.
Tried UDP 5198 thru 5200, Netopia returned an overlap error, but allowed me to try it anyway, results: Nil

Tried my ISP assigned IP on manual instead of dynamic DHCP, made sure router pinholes were designated over to Mac IP, results: Nil

Checked my account with echolink - still valid.

If I ever get it to work, I'll post the steps/results here with graphics or video.

Thanks again, for your advice.

Posts: 47

« Reply #7 on: October 13, 2007, 08:19:24 AM »

I just re-read your first post and your example of the port forwarding settings. If you do indeed have the internal IP address pointing at, I would think that incorrect as that is the entire network (sort of) Hope that's a typo, unless the Netopia is really strange in how it handles NAT and port forwarding.
It should point to the address you have assigned to the Mac running EchoMac.

Did you also say you had tried all this with the Netopia firewall disabled? If not, maybe you require a firewall rule to allow echomac traffic in and out (I do)

I've always loved networking, sort of like working in the dark with my eyes closed.

Posts: 74

« Reply #8 on: November 12, 2007, 11:58:27 AM »

Hi WB6NGC, my typo, it was pointing to 1922.168.1.2
Since last QSO on line, I physically took my Powerbook (MacBook) pro over to my ISP.  Then I connected directly to a T-1 line without the use of my router.  

Signs and symptoms were the same; I could receive the list of stations but could not connect.  Tried several while the engineer watched and no results.  

I switched over to Parallels and ran EchoLINK under windows xp; same signs and symptoms, no connect.  

It would appear that my router is not to blame; this leaves 2 Macs that won't connect, so the only thing to do is to re-look all my settings.

The first thing I did was go to the echo link website and make sure my account is valid and pw is correct.

Looking over Network settings:

Location Automatic, Built in Ethernet, Using DHCP,,
Configure IPv6 is automatically.

PPOE: Not used
Appletalk: OFF
Proxies, Manually, none being used
"Use Passive FTP Mode (PASV)" is checked.
Ethernet is Config Automatically

Sharing, Services, Personal File Sharing ON
Firewall: Personal File Sharing ON

Specified Ports:
Port Name: Other
TCP Port Number 5200
UDP Port Number 5198-5199
Description: Echomac 5200

Port Name Other
TCP Port Numbers 5200
UDP Port Numbers 5198-5200
Description: Echomac

Note: Also tried other variations of the above.

Internet Sharing is set to OFF

Any assist will be most appreciated.  

Posts: 47

« Reply #9 on: November 13, 2007, 01:55:20 PM »

Do you happen to have any 3rd party network tools installed, such as Lil'Snitch? Something that can specifically block outgoing network activity from an application is what it sounds like you are suffering. It would have been nice to hear from the ISP tech whether you had outgoing connection attempts or if the incoming replies are being blocked. Sadly echomac has little logging help. So there is still the question if it is your outgoing udp connection packets or the return replies that is causing the break.
At least you can be pretty certain it is on your Macbook that the problem lies. What would be interesting would be to find a buddy nearby who has it all working on a laptop that can come to your house and try, just to be sure it isn't your ISP blocking ports that is the problem.


Posts: 74

« Reply #10 on: November 13, 2007, 04:53:50 PM »

Yes, I am a Lil'Snitch user; I set up Lil'Snitch to allow EchoMac to use any port and any protocol; later I tried it with Lil'Snitch filtering off.  Unfortunately, for me, results were still nil.

I haven't tried it with System Leopard yet, I have it installed on an external firewire drive; I'll boot to it, try Echomac with it and see what happens.  If that fails, I'll install System Leopard on another external using a regular install (not an upgrade).  

After that, if that fails, I guess I could get the ISP engineer to monitor my data stream.  It must be someting improper with my network settings; I even tried a wi fi connection on a neighbor's house to an unsecure wireless router (yeah, I know, slap, slap), using a MFJ-1800 yagi antenna.

Do my various settings (my previous message) look ok to you?

Thanks again,

Posts: 47

« Reply #11 on: November 14, 2007, 11:33:19 AM »

As far as I can see, the settings look okay.
Was the neighbor on a different ISP?  Guess you have already tried that too.

Here's a thought. Create a new user on the Mac and try from that user. I suppose you have essentially already done this.
Leopard will give you (perhaps) a whole new list of troubles.

And now I'm being silly, but could you have ever pissed off the EchoMac author and he is filtering you?  
But you said echolink does the same thing.
Gads, I thought I had bad karma.

I'll bet when you finally solve it, it will be something simple and we will all give ourselves concussions from the forehead slap.

I'm still thinking


Posts: 47

« Reply #12 on: November 14, 2007, 12:22:44 PM »

Okay. So you get the list, that means your username and password and servers are okay.

You have bypassed both software and hardware firewalls to eliminate their blocking UDP 5198-5199 IN and OUT

You have used alternate ISP in case your ISP is blocking unused ports

Once you go online, can you watch the router activity led (if exists) and see if it looks like there's activity when you double-click on the ECHOTEST entry. Looking to verify outgoing UDP from your Mac. Tried enabling logging
in the Firewall/Advanced pane? Then do a few test connects and then see if the log shows anything.

I just dropped into leopard and with the firewall in its default off state, EchoMac worked for me. I could connect to the echotest

Well, that's all I can think of for now. Guess I'll go get a piece of rhubarb pie and clear my mind.


Posts: 47

« Reply #13 on: November 14, 2007, 01:21:06 PM »

I just checked this on another Mac. I don't have echomac firewall ports defined at all. LilSnitch has the ports, instead.
So, try deleting the two "other" firewall defs you made for echomac. Then delete the rules in lil snitch. Should be 3.

Echo Mac

Then try running Echo Mac again and connecting to ECHOTEST

Lil Snitch should ask ok for Echo Mac, then echolinux then echoaudio. Allow all 3 forever and see what happens.


Posts: 74

« Reply #14 on: November 14, 2007, 08:41:07 PM »

Thanks for keeping up with me.

I got in partially.  I went to Echomac preferences and reduced the station information from the long default to less than 23 characters.  Tried Echo Test, echo audio, node 9999, nothing.

Went to the sound control panel, made tested my sound input, it works fine, made sure sound output was ok, closed sound control panel.

For the first time, echomac (lower left) presented number of stations online.  Growl preferences, for the first time, indicated connected or disconnected.  Then I got connected to Echo audio, it showed the ip number, for the first time, in the connected to box.

However..., Push toggle to transmit went gray and would not allow transmit.  Previously, during unsuccessful attempts to connect, the push to transmit would turn red or off, but made no difference.  

Lil Snitch became an unintentional notification system of network activity; in these cases, Snitch presented me with a 4th option to allow both the IP and the port simultaneously (which it didn't do before).

Presently, further attempts to do echotest are unsuccessful.

Am I supposed to check the Busy check box in every attempt?  I've been trying both ways.
Pages: [1] 2 Next   Go Up
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!