eHam.net - Amateur Radio (Ham Radio) Community

Call Search
     

New to Ham Radio?
My Profile

Community
Articles
Forums
News
Reviews
Friends Remembered
Strays
Survey Question

Operating
Contesting
DX Cluster Spots
Propagation

Resources
Calendar
Classifieds
Ham Exams
Ham Links
List Archives
News Articles
Product Reviews
QSL Managers

Site Info
eHam Help (FAQ)
Support the site
The eHam Team
Advertising Info
Vision Statement
About eHam.net


Categories | Power Supplies | MFJ-4275MV Help

Show all reviews of the MFJ-4275MV

You can write your own review of the MFJ-4275MV.

WA6ZHE  Rating: 1/5 Feb 17, 2019 09:17  Send this review to a friend!
Not Too Great  Time owned: 6 to 12 months
I bought this one to power my ALS-500M, which it appears others have done as well. It worked fine until just the other day. I was listening on 40, linear was powered off, but the 4275 was on. In fact I had not transmitted for at least 30 minutes. I heard a little "plink" which sounds similar to an auto switch powering off. The Fault light came on, and I attempted to power it off. No way, no how, would this power supply power off until I pulled the AC plug. After waiting about an hour, I plugged the AC in again, and right off the bat the supply came on, with the fault light. Of course I had made sure the power switch was still off. Will update if I ever figure this out. This only powers the linear amp; my Kenwood is on an Astron power supply.  
Product is in production.
Email Subscription
You are not subscribed to this review.

Subscribe!
My Subscriptions
Subscriptions Help


If you have any questions, problems, or suggestions about Reviews please email your Reviews Manager